CVE-2026-57198: Asterisk: Possible RED T.140 Heap Buffer Overflow

Published Oct 27, 2026
·
Updated

Asterisk is an open source private branch exchange and telephony toolkit. In affected deployments, an authenticated attacker may cause a T.140 RED heap buffer overflow using carefully crafted packets, potentially allowing remote code execution or causing Asterisk to crash. The chansip channel driver must be installed and configured, and its textsupport option must be enabled; textsupport defaults to no. The chansip driver was deprecated in Asterisk 20 and completely removed in all later versions. Repository comparisons verify patch containment in Asterisk 20.20.1, 21.12.3, 22.10.1 and 23.4.1, and Certified Asterisk 20.7-cert11 and 22.8-cert3. The affected release-track scope remains unresolved: structured metadata includes later release tracks even though the advisory says the required chansip driver was removed there.

Affected Software

1 affected component
Sangoma Asterisk<20.20.1, <21.12.3, <22.10.1, <23.4.1, <20.7-cert11, <22.8-cert3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 20.20.1
  2. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 21.12.3
  3. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 22.10.1
  4. Upgrade

    Upgrade Asterisk to a version that resolves this vulnerability.

    Fixed in 23.4.1
  5. Upgrade

    Upgrade Certified Asterisk to a version that resolves this vulnerability.

    Fixed in 20.7-cert11
  6. Upgrade

    Upgrade Certified Asterisk to a version that resolves this vulnerability.

    Fixed in 22.8-cert3

Event History

Oct 27, 2026
CVE Published
via MITRE·04:47 PM
Data Sourced
via MITRE·04:47 PM
DescriptionWeakness

Frequently Asked Questions

1

Which deployments are realistically exposed?

Exposure requires the deprecated chan_sip channel driver to be installed and configured, with its textsupport option enabled. Deployments that do not use chan_sip, or leave textsupport disabled, do not meet the stated prerequisites; textsupport defaults to no.

2

What access and input does an attacker need?

The issue is described as exploitable by an authenticated attacker who sends carefully crafted T.140 RED packets. Successful exploitation may result in remote code execution or an Asterisk crash.

3

Which versions are confirmed to contain the patch?

Patch containment is verified in Asterisk 20.20.1, 21.12.3, 22.10.1, and 23.4.1, plus Certified Asterisk 20.7-cert11 and 22.8-cert3.

4

What can be done if updating is not immediately possible?

Disable chan_sip textsupport, or remove/avoid use of the chan_sip driver where operationally feasible. This removes the stated configuration prerequisite for exploitation.

5

Does this apply to later Asterisk releases?

The advisory states that chan_sip was deprecated in Asterisk 20 and completely removed in later versions. However, the affected release-track scope is unresolved because structured metadata includes later tracks despite that removal.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203