CVE-2026-57203: Asterisk: Local privilege escalation through ast_loggrabber's world-writable helper location
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, astloggrabber executes a Python script from the world-writable /tmp directory. An attacker already authorized to open a shell session on the Asterisk server may place a malicious script there and gain elevated privileges or execute code when an administrator runs astloggrabber as a user with elevated privileges. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Asteriskto a version that resolves this vulnerability.Fixed in 20.20.1 - Upgrade
Upgrade
Asteriskto a version that resolves this vulnerability.Fixed in 21.12.3 - Upgrade
Upgrade
Asteriskto a version that resolves this vulnerability.Fixed in 22.10.1 - Upgrade
Upgrade
Asteriskto a version that resolves this vulnerability.Fixed in 23.4.1 - Upgrade
Upgrade
Certified Asteriskto a version that resolves this vulnerability.Fixed in 20.7-cert11 - Upgrade
Upgrade
Certified Asteriskto a version that resolves this vulnerability.Fixed in 22.8-cert3
Event History
Frequently Asked Questions
Who can exploit this issue?
An attacker must already be authorized to open a shell session on the Asterisk server. They can place a malicious Python script in /tmp, where the helper location is world-writable.
What event triggers exploitation?
The malicious script is executed when an administrator runs ast_loggrabber as a user with elevated privileges. Successful exploitation can provide elevated privileges or code execution.
Are all Asterisk releases affected?
The issue affects releases prior to Asterisk 20.20.1, 21.12.3, 22.10.1, and 23.4.1, as well as Certified Asterisk releases prior to 20.7-cert11 and 22.8-cert3.
What should be done to remediate the issue?
Upgrade to Asterisk 20.20.1, 21.12.3, 22.10.1, or 23.4.1, or to Certified Asterisk 20.7-cert11 or 22.8-cert3.