CVE-2026-58016: Glib: integer underflow in gio/gdbusintrospection.c via "g_dbus_node_info_new_for_xml"

Published Jun 24, 2026
·
Updated

A flaw was found in GLib. A state confusion issue exists in gdbusnodeinfonewforxml() in the gio/gdbusintrospection.c file when processing malformed D-Bus introspection XML, specifically with a node element nested within other elements like method, signal, property or arg. This issue can cause an unsigned integer overflow and lead to an out-of-bounds read, resulting in a denial of service.

Other sources

A state confusion vulnerability exists in gdbusnodeinfonewforxml() in gio/gdbusintrospection.c. When parsing malformed D-Bus introspection XML containing a <node> element nested inside <method>, <signal>, <property>, or <arg> elements, the parser's internal state becomes inconsistent. The nested </interface> closing tag inside the nested <node> steals and resets the shared data->methods (or data->signals/data->properties) array to an empty state. When the outer </method> (or similar) closing tag subsequently calls parsedatagetmethod(data, FALSE), it accesses pdata[len - 1] with len == 0, causing an unsigned integer underflow (0u - 1 = 0xFFFFFFFF) and a massive out-of-bounds heap read at offset 0xFFFFFFFF sizeof(gpointer) (~8 GB before the buffer).

— Red Hat

Glib: integer underflow in gio/gdbusintrospection.c via "gdbusnodeinfonewforxml"

— Microsoft

Affected Software

36 affected componentsFixes available
GLib g_dbus_node_info_new_for_xml
Microsoft azl3 glib 2.78.6-9<2.78.6-10
2.78.6-10
Gnome GLib<2.89.0
redhat Cert-manager Operator Openshift>=1.18.0<1.18.2
redhat Cert-manager Operator Openshift=1.17.0
redhat Cert-manager Operator Openshift=1.20.0
redhat Codeready Linux Builder=8.0
redhat Codeready Linux Builder=9.0
redhat Codeready Linux Builder=10.0
redhat Codeready Linux Builder Eus=9.6
redhat Codeready Linux Builder Eus=10.0
redhat Discovery=2.0
redhat Insights-proxy=1.5.0
redhat OpenShift AI>=3.0<3.0.3
redhat OpenShift AI>=3.2<3.2.3
redhat OpenShift AI>=3.4<3.4.3
redhat Update Infrastructure>=5.0<5.2
redhat Enterprise Linux=6.0
redhat Enterprise Linux=8.0
redhat Enterprise Linux=9.0
redhat Enterprise Linux=10.0
redhat Enterprise Linux Aus=8.4
redhat Enterprise Linux Aus=8.6
redhat Enterprise Linux Els=7.0
redhat Enterprise Linux Eus=8.4
redhat Enterprise Linux Eus=8.6
redhat Enterprise Linux Eus=9.6
redhat Enterprise Linux Eus=10.0
redhat Enterprise Linux Server Tus=8.8
redhat Enterprise Linux Update Services For Sap Solutions=8.8
redhat Enterprise Linux Update Services For Sap Solutions=9.2
redhat Enterprise Linux Update Services For Sap Solutions=9.4
debian/glib2.0*
debian/glib2.0<2.84.4-3~deb13u4
2.84.4-3~deb13u4
debian/glib2.0<2.88.3-2
2.88.3-2
debian/glib2.0<=2.74.6-2+deb12u9, <=2.74.6-2+deb12u2
2.84.4-3~deb13u52.90.1-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.78.6-10
  2. Upgrade

    Upgrade debian/glib2.0 to a version that resolves this vulnerability.

    Fixed in 2.84.4-3~deb13u4
  3. Upgrade

    Upgrade debian/glib2.0 to a version that resolves this vulnerability.

    Fixed in 2.88.3-2
  4. Upgrade

    Upgrade debian/glib2.0 to a version that resolves this vulnerability.

    Fixed in 2.84.4-3~deb13u5Fixed in 2.90.1-2

Event History

Jun 24, 2026
Data Sourced
via Red Hat·05:34 PM
DescriptionSeverityAffected Software
Jun 30, 2026
CVE Published
via MITRE·01:02 PM
Data Sourced
via MITRE·01:02 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·01:19 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:19 PM
Affected Software
Jul 1, 2026
Data Sourced
via Microsoft·08:01 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2026-58016?

CVE-2026-58016 has a critical severity rating of 9.1.

2

How do I fix CVE-2026-58016?

To address CVE-2026-58016, users should update GLib to the latest version provided by Red Hat or the relevant vendor.

3

What type of vulnerability is CVE-2026-58016?

CVE-2026-58016 is categorized as an integer underflow vulnerability.

4

Which software is affected by CVE-2026-58016?

CVE-2026-58016 affects GLib and is relevant to systems running Red Hat Enterprise Linux.

5

Is CVE-2026-58016 remotely exploitable?

Yes, CVE-2026-58016 is remotely exploitable, as it involves a state confusion issue when processing malformed D-Bus introspection XML.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203