CVE-2026-59797: Apache HTTP Server: mod_ssl SSLRequire allows .htaccess ap_expr file-function
Published Oct 1, 2026
·Updated
Apache HTTP Server: modssl SSLRequire allows .htaccess apexpr file-function
Other sources
Improper Privilege Management vulnerability in Apache HTTP Server's modssl via SSLRequire and file-related expressions.
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
— MITRE
Affected Software
3 affected componentsFixes available
Apache HTTP Server>=2.4.0<=2.4.68
Apache HTTP Server>=2.4.0<2.4.69
Microsoft azl3 httpd 2.4.68-1<2.4.69-1
2.4.69-1
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 2.4.69-1
Event History
Oct 1, 2026
CVE Published
via MITRE·04:08 PM
Data Sourced
via MITRE·04:08 PM
DescriptionWeakness
Data Sourced
via NVD·05:17 PM
DescriptionSeverityWeaknessAffected Software
Oct 9, 2026
Data Sourced
via Microsoft·08:25 AM
DescriptionSeverityWeaknessAffected Software
Frequently Asked Questions
1
Which Apache HTTP Server versions should be treated as affected?
Apache HTTP Server versions 2.4.0 through 2.4.68 are identified as affected.
2
Is a fixed release or workaround identified in the provided information?
No fixed release or mitigation is specified in the provided information.