CVE-2026-63924: ipv6: exthdrs: refresh nh pointer after ipv6_hop_jumbo()

Published Jul 19, 2026
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

Affected Software

26 affected componentsFixes available
Linux Linux kernel
debian/linux
6.1.176-16.1.187-16.12.107-16.12.111-17.2.8-17.2.9-1
Linux Linux kernel>=2.6.12.1<5.10.259
Linux Linux kernel>=5.11<5.15.210
Linux Linux kernel>=5.16<6.1.176
Linux Linux kernel>=6.2<6.6.143
Linux Linux kernel>=6.7<6.12.93
Linux Linux kernel>=6.13<6.18.35
Linux Linux kernel>=6.19<7.0.12
Linux Linux kernel=2.6.12
Linux Linux kernel=2.6.12-rc2
Linux Linux kernel=2.6.12-rc3
Linux Linux kernel=2.6.12-rc4
Linux Linux kernel=2.6.12-rc5
Linux Linux kernel=7.1-rc1
Linux Linux kernel=7.1-rc2
Linux Linux kernel=7.1-rc3
Linux Linux kernel=7.1-rc4
Linux Linux kernel=7.1-rc5
linux/kernel>=2.6.12<5.10.259
5.10.259
linux/kernel>=5.11.0<5.15.210
5.15.210
linux/kernel>=5.16.0<6.1.176
6.1.176
linux/kernel>=6.2.0<6.6.143
6.6.143
linux/kernel>=6.7.0<6.12.93
6.12.93
linux/kernel>=6.13.0<6.18.35
6.18.35
linux/kernel>=6.19.0<7.0.12
7.0.12

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.187-1Fixed in 6.12.107-1Fixed in 6.12.111-1Fixed in 7.2.8-1Fixed in 7.2.9-1
  2. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.10.259
  3. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.15.210
  4. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.1.176
  5. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.6.143
  6. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.12.93
  7. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.18.35
  8. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 7.0.12

Event History

Jul 19, 2026
CVE Published
via MITRE·02:55 PM
Data Sourced
via MITRE·02:55 PM
DescriptionSeverity
Data Sourced
via OSV·02:55 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·04:17 PM
RemedyDescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2026-63924?

CVE-2026-63924 has a critical severity rating of 9.8.

2

What is CVE-2026-63924 about?

CVE-2026-63924 is a vulnerability in the Linux kernel related to incorrect handling of the next header pointer during the ipv6_hop_jumbo() function.

3

How do I fix CVE-2026-63924?

To fix CVE-2026-63924, you should update to the latest patched version of the Linux kernel.

4

What systems are affected by CVE-2026-63924?

CVE-2026-63924 affects systems running vulnerable versions of the Linux kernel with IPv6 support.

5

Is there a workaround for CVE-2026-63924?

Currently, there are no known workarounds for CVE-2026-63924; applying the patch is the recommended method of mitigation.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203