CVE-2026-66759: Gimp: out-of-bounds read in file-icns plugin causes information disclosure or crash on crafted icns images

Published Jul 27, 2026
·
Updated

A flaw was found in the file-icns plugin in GIMP, affecting versions 2.99.14 and newer. When applying a decompressed mask during ICNS image processing, the plugin reads from the mask data buffer without verifying if the cursor exceeds the allocated resource size. If a crafted file contains a truncated mask resource, the icnsdecompress function continues reading past the bounds of the buffer. This out-of-bounds read vulnerability results in information disclosure of heap contents, where memory contents are leaked as alpha channel pixel values, or a crash leading to a denial of service if unmapped memory is accessed.

Other sources

A flaw was found in the file-icns plugin in GIMP. When applying a decompressed mask during ICNS image processing, the plugin reads from the mask data buffer without verifying if the cursor exceeds the allocated resource size. If a crafted file contains a truncated mask resource, the icnsdecompress function continues reading past the bounds of the buffer. This out-of-bounds read vulnerability results in information disclosure of heap contents, where memory contents are leaked as alpha channel pixel values, or a crash leading to a denial of service if unmapped memory is accessed.

— MITRE

Affected Software

11 affected componentsFixes available
GIMP file-icns plugin>=undefined
debian/gimp<=2.10.34-1+deb12u10
3.0.4-3+deb13u103.0.4-3+deb13u113.2.6-13.2.8-1
GIMP GIMP=3.0.8
GIMP GIMP=3.2.4
redhat Enterprise Linux=6.0
redhat Enterprise Linux=7.0
redhat Enterprise Linux=8.0
redhat Enterprise Linux=9.0
debian/gimp*
debian/gimp<3.0.4-3+deb13u10
3.0.4-3+deb13u10
debian/gimp<3.2.6-1
3.2.6-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/gimp to a version that resolves this vulnerability.

    Fixed in 3.0.4-3+deb13u10Fixed in 3.0.4-3+deb13u11Fixed in 3.2.6-1Fixed in 3.2.8-1
  2. Upgrade

    Upgrade debian/gimp to a version that resolves this vulnerability.

    Fixed in 3.0.4-3+deb13u10
  3. Upgrade

    Upgrade debian/gimp to a version that resolves this vulnerability.

    Fixed in 3.2.6-1

Event History

Jul 27, 2026
Data Sourced
via Red Hat·04:02 PM
DescriptionSeverityAffected Software
CVE Published
via MITRE·07:12 PM
Data Sourced
via MITRE·07:12 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·07:17 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·07:17 PM
Affected Software
Exploit Published
via CISA·07:25 PM

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2026-66759?

CVE-2026-66759 has a severity rating of high at 7.1.

2

How do I fix CVE-2026-66759?

To fix CVE-2026-66759, update the GIMP file-icns plugin to the latest version that addresses this vulnerability.

3

What systems are affected by CVE-2026-66759?

CVE-2026-66759 affects GIMP versions 2.99.14 and newer.

4

What type of vulnerability is CVE-2026-66759?

CVE-2026-66759 is an out-of-bounds read vulnerability that can lead to information disclosure or application crashes.

5

Can CVE-2026-66759 be exploited remotely?

Yes, CVE-2026-66759 can potentially be exploited remotely through crafted ICNS image files.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203