CVE-2026-69243: AIOHTTP: HTTP request smuggling via WebSocket upgrade
Summary
The HTTP parsers were vulnerable to a request smuggling attack relating to WebSocket upgrades.
Impact
If using the server-side component, it may be possible for an attacker to execute a request smuggling vulnerability using an edge case in the WebSocket upgrade procedure. AIOHTT is unaware of any public exploit code.
---
Patch: https://github.com/aio-libs/aiohttp/commit/6ae358f0983c3f4d6f67692b2f8e65dc8e091c98
Other sources
AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to 3.14.2, the HTTP parsers were vulnerable to a request smuggling attack relating to WebSocket upgrades. If using the server-side component, an attacker may be able to execute a request smuggling vulnerability using an edge case in the WebSocket upgrade procedure. A WebSocket upgrade request with a body could cause the parser to switch protocols before the complete request body was received, leaving trailing bytes to be handled as upgraded-protocol or pipelined data rather than normal HTTP body data. This issue is fixed in version 3.14.2.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
pip/aiohttpto a version that resolves this vulnerability.Fixed in 3.14.2 - Upgrade
Upgrade
debian/python-aiohttpto a version that resolves this vulnerability.Fixed in 3.8.4-1+deb12u2 - Upgrade
Upgrade
debian/python-aiohttpto a version that resolves this vulnerability.Fixed in 3.14.3-1 - Upgrade
Upgrade
debian/python-aiohttpto a version that resolves this vulnerability.Fixed in 3.8.4-1+deb12u2Fixed in 3.14.3-1 - Upgrade
Upgrade
aiohttpto a version that resolves this vulnerability.Fixed in 3.14.2Patch 6ae358f0983c3f4d6f67692b2f8e65dc8e091c98
Event History
Frequently Asked Questions
What is the severity of CVE-2026-69243?
CVE-2026-69243 has a medium severity score of 6.3 based on the CVSS v4.0 metrics.
What impact does CVE-2026-69243 have?
CVE-2026-69243 may allow an attacker to exploit a request smuggling vulnerability when using the server-side component during the WebSocket upgrade process.
How do I fix CVE-2026-69243?
To fix CVE-2026-69243, ensure you update to the latest version of the aiohttp library that addresses this vulnerability.
Is CVE-2026-69243 exploitable remotely?
Yes, CVE-2026-69243 can be exploited remotely, as it involves HTTP requests.
Which software is affected by CVE-2026-69243?
CVE-2026-69243 affects the aiohttp library, commonly installed via pip.