CVE-2026-73637: Apache HTTP Server: mod_auth_digest DoS attack

Published Oct 1, 2026
·
Updated

Apache HTTP Server: modauthdigest DoS attack

Other sources

Use after free in modauthdigest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause authentication state corruption via concurrent Digest authentication requests when AuthDigestNcCheck is enabled or AuthDigestNonceLifetime is set to 0.

— Launchpad

Affected Software

4 affected componentsFixes available
Apache HTTP Server<2.4.69
Apache HTTP Server>=2.4.0<2.4.69
Microsoft azl3 httpd 2.4.68-1<2.4.69-1
2.4.69-1
debian/apache2<=2.4.68-1~deb12u1, <=2.4.67-1~deb12u3, <=2.4.68-1~deb13u1, <=2.4.67-1~deb13u3
2.4.69-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.4.69-1
  2. Upgrade

    Upgrade debian/apache2 to a version that resolves this vulnerability.

    Fixed in 2.4.69-1
  3. Upgrade

    Upgrade Apache HTTP Server to a version that resolves this vulnerability.

    Fixed in 2.4.69

Event History

Oct 1, 2026
CVE Published
via MITRE·04:18 PM
Data Sourced
via MITRE·04:18 PM
DescriptionWeakness
Data Sourced
via NVD·05:17 PM
DescriptionSeverityWeaknessAffected Software
Oct 9, 2026
Data Sourced
via Microsoft·08:26 AM
DescriptionSeverityWeaknessAffected Software
Oct 15, 2026
Data Sourced
via Ubuntu·09:53 PM
RemedyDescriptionSeverityAffected Software
Data Sourced
via Launchpad·09:54 PM
Description
Data Sourced
via Debian·09:54 PM
DescriptionAffected Software

Frequently Asked Questions

1

Which configurations are affected?

The issue affects Apache HTTP Server versions before 2.4.69 when mod_auth_digest is in use and either AuthDigestNcCheck is enabled or AuthDigestNonceLifetime is set to 0.

2

Does exploitation require authentication?

No. An unauthenticated remote client can trigger the authentication state corruption by sending concurrent Digest authentication requests.

3

What is the recommended remediation?

Upgrade Apache HTTP Server to version 2.4.69, which fixes the issue.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203