CVE-2026-76222: GitPython before 3.1.58 Path Traversal via .gitmodules Submodule Name

Published Aug 19, 2026
·
Updated

GitPython before 3.1.58 fails to validate submodule names from .gitmodules files, allowing attackers to create Git repositories at arbitrary filesystem paths outside the intended clone directory. Attackers can craft malicious repositories with traversal sequences in submodule names that GitPython processes during submodule initialization, creating attacker-controlled Git repositories at escaped filesystem locations.

Affected Software

7 affected componentsFixes available
GitPython GitPython<3.1.58
Gitpython Project Gitpython Python<3.1.58
debian/python-git<3.1.30-1+deb12u3
3.1.30-1+deb12u3
debian/python-git<3.1.44-1+deb13u1
3.1.44-1+deb13u1
debian/python-git<3.1.61-1
3.1.61-1
debian/python-git<=3.1.30-1+deb12u2, <=3.1.44-1
3.1.30-1+deb12u33.1.44-1+deb13u13.2.1-1
alpine/py3-gitpython<3.1.61-r0
3.1.61-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/python-git to a version that resolves this vulnerability.

    Fixed in 3.1.30-1+deb12u3
  2. Upgrade

    Upgrade debian/python-git to a version that resolves this vulnerability.

    Fixed in 3.1.44-1+deb13u1
  3. Upgrade

    Upgrade debian/python-git to a version that resolves this vulnerability.

    Fixed in 3.1.61-1
  4. Upgrade

    Upgrade debian/python-git to a version that resolves this vulnerability.

    Fixed in 3.1.30-1+deb12u3Fixed in 3.1.44-1+deb13u1Fixed in 3.2.1-1
  5. Upgrade

    Upgrade alpine/py3-gitpython to a version that resolves this vulnerability.

    Fixed in 3.1.61-r0

Event History

Aug 19, 2026
CVE Published
via MITRE·02:02 PM
Data Sourced
via MITRE·02:02 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·02:17 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:17 PM
DescriptionSeverityAffected Software
Data Sourced
via Red Hat·02:18 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What conditions are required for exploitation?

An attacker must persuade a user or system to process a malicious repository containing a crafted .gitmodules file during GitPython submodule initialization. No attacker privileges are required, but user interaction is required.

2

Which deployments are exposed?

GitPython versions before 3.1.58 are affected when they initialize submodules from repositories whose .gitmodules content may be attacker-controlled or untrusted.

3

What is the impact of a successful exploit?

A malicious submodule name containing traversal sequences can cause GitPython to create attacker-controlled Git repositories at filesystem locations outside the intended clone directory. The vulnerability has high severity, with integrity impact rated high and availability impact rated low.

4

What should be done if an immediate upgrade is not possible?

Avoid initializing submodules from untrusted repositories or repositories with untrusted .gitmodules files. Treat repositories that use traversal sequences in submodule names as unsafe until GitPython can be updated to 3.1.58 or later.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203