CVE-2026-86138: Integer Overflow
Published Sep 5, 2026
·Updated
In libxml2 before 2.15.4, xmlDictAddQString in dict.c has an integer overflow and resultant heap-based buffer overflow.
Affected Software
7 affected componentsFixes available
libxml2 libxml2<2.15.4
Xmlsoft Libxml2<2.15.4
Microsoft azl3 libxml2 2.11.5-10<2.11.5-11
2.11.5-11
Microsoft azl3 libxml2 2.11.5-11<2.11.5-11
2.11.5-11
debian/libxml2<=2.9.14+dfsg-1.3~deb12u6, <=2.9.14+dfsg-1.3~deb12u4, <=2.12.7+dfsg+really2.9.14-2.1+deb13u3, <=2.12.7+dfsg+really2.9.14-2.1+deb13u1
2.15.4+dfsg-1
IBM MQ Operator<=SC2: v3.2.0 - v3.2.29
CD: v3.3.0, v3.4.0, v3.4.1, v3.5.0, v3.5.1 - v3.5.3, v3.6.0 - v3.6.4, v3.7.0 - v3.7.2, v3.8.0, v3.8.1, v3.9.0, v3.9.1, v3.9.2, v4.0.0, v4.0.1, v4.0.2, v4.0.3, v4.0.4
LTS: v2.0.0 - 2.0.29
IBM supplied MQ Advanced container images<=SC2: 9.4.0.6-r1, 9.4.0.6-r2, 9.4.0.7-r1, 9.4.0.10-r1, 9.4.0.10-r2, 9.4.0.11-r1, 9.4.0.11-r2, 9.4.0.11-r3, 9.4.0.12-r1, 9.4.0.15-r1 - 9.4.0.15-r4, 9.4.0.16-r1, 9.4.0.16-r2, 9.4.0.17-r1, 9.4.0.17-r2, 9.4.0.20-r1, 9.4.0.21-r1, 9.4.0.21-r2, 9.4.0.25-r1 - 9.4.0.25-r3, 9.4.0.26-r1CD: 9.4.1.0-r1, 9.4.1.0-r2, 9.4.1.1-r1, 9.4.2.0-r1, 9.4.2.0-r2, 9.4.2.1-r1, 9.4.2.1-r2, 9.4.3.0-r1, 9.4.3.0-r2, 9.4.3.1-r1 - 9.4.3.1-r3, 9.4.4.0-r1 - 9.4.4.0-r4, 9.4.4.1-r1, 9.4.5.0-r1, 9.4.5.0-r2, 9.4.5.1-r1, 10.0.0.0-r1 - 10.0.0.0-r4, 10.0.0.5-r1LTS: 9.3.0.0-r1, 9.3.0.0-r2, 9.3.0.0-r3, 9.3.0.1-r1, 9.3.0.1-r2, 9.3.0.1-r3, 9.3.0.1-r4, 9.3.0.3-r1, 9.3.0.4-r1, 9.3.0.4-r2, 9.3.0.5-r1, 9.3.0.5-r2, 9.3.0.5-r3, 9.3.0.6-r1, 9.3.0.10-r1, 9.3.0.10-r2, 9.3.0.11-r1,9.3.0.11-r2, 9.3.0.15-r1, 9.3.0.16-r1, 9.3.0.16-r2, 9.3.0.17-r1, 9.3.0.17-r2, 9.3.0.17-r3, 9.3.0.20-r1, 9.3.0.20-r2, 9.3.0.21-r1, 9.3.0.21-r2, 9.3.0.21-r3, 9.3.0.25-r1, 9.4.0.0-r1, 9.4.0.0-r2, 9.4.0.0-r3, 9.4.0.5-r1, 9.4.0.5-r2
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 2.11.5-11 - Upgrade
Upgrade
debian/libxml2to a version that resolves this vulnerability.Fixed in 2.15.4+dfsg-1
Event History
Sep 5, 2026
CVE Published
via MITRE·04:21 AM
Data Sourced
via MITRE·04:21 AM
DescriptionSeverityWeakness
Data Sourced
via Red Hat·04:31 AM
DescriptionSeverityAffected Software
Data Sourced
via NVD·05:17 AM
RemedyDescriptionSeverityWeaknessAffected Software
Sep 6, 2026
Data Sourced
via Microsoft·11:36 AM
DescriptionSeverityWeaknessAffected Software
Oct 15, 2026
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software
Frequently Asked Questions
1
What level of access does an attacker need?
The attack vector is local and requires no privileges or user interaction. Exploitation has high attack complexity.
2
Which installations are affected?
Installations using libxml2 versions before 2.15.4 are affected. Version 2.15.4 is the first version indicated as not affected by the provided data.
3
How can I determine whether my environment is exposed?
Identify the libxml2 version in use by the affected application or system package. Versions earlier than 2.15.4 should be treated as affected.