CVE-2026-87018: undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation

Published Oct 15, 2026
·
Updated

Impact

undici crashes the client process when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with ERRTLSCERTALTNAMEINVALID. undici's established socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught AssertionError that terminates the Node.js process. Both the HTTP/1.1 and HTTP/2 paths are affected.

A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process. Only TLS 1.2 is affected, because TLS 1.3 does not support renegotiation. Exploitation does not require a CA compromise: the attacker controls the endpoint and can present two ordinary valid certificates, the first matching the requested URL and the second intentionally not matching it.

Patches

Upgrade to undici 6.29.1, 7.30.1, or 8.12.2.

Workarounds

Restrict outbound connections to TLS 1.3, for example by setting connect: { minVersion: 'TLSv1.3', maxVersion: 'TLSv1.3' } on the client or agent, so that renegotiation cannot occur, when the target endpoints support TLS 1.3.

Other sources

undici is an HTTP client library for Node.js. In versions 4.2.1 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, the client process crashes when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with a certificate-altname error, but undici's established-socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught assertion that terminates the Node.js process, affecting both the HTTP/1.1 and HTTP/2 paths. A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process, and exploitation needs no CA compromise because the attacker controls the endpoint and can present two ordinary valid certificates. Only TLS 1.2 is affected, since TLS 1.3 does not support renegotiation. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, restrict outbound connections to TLS 1.3 so renegotiation cannot occur, when the target endpoints support it.

— MITRE

Affected Software

14 affected componentsFixes available
npm/undici>=4.2.1<=6.29.0, >=7.0.0<=7.30.0, >=8.0.0<=8.12.1
Nodejs Undici Node.js>=4.2.1<6.29.1
Nodejs Undici Node.js>=7.0.0<7.30.1
Nodejs Undici Node.js>=8.0.0<8.12.2
npm/undici>=8.0.0<8.12.2
8.12.2
npm/undici>=7.0.0<7.30.1
7.30.1
npm/undici>=4.2.1<6.29.1
6.29.1
ubuntu/node-undici*
ubuntu/node-undici*
ubuntu/node-undici*
debian/node-undici*
debian/node-undici*
debian/node-undici<8.12.2+dfsg+~cs3.2.3-1
8.12.2+dfsg+~cs3.2.3-1
debian/node-undici<=5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4, <=5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3, <=7.3.0+dfsg1+~cs24.12.11-1
8.12.2+dfsg+~cs3.2.3-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade npm/undici to a version that resolves this vulnerability.

    Fixed in 8.12.2
  2. Upgrade

    Upgrade npm/undici to a version that resolves this vulnerability.

    Fixed in 7.30.1
  3. Upgrade

    Upgrade npm/undici to a version that resolves this vulnerability.

    Fixed in 6.29.1
  4. Upgrade

    Upgrade debian/node-undici to a version that resolves this vulnerability.

    Fixed in 8.12.2+dfsg+~cs3.2.3-1
  5. Upgrade

    Upgrade debian/node-undici to a version that resolves this vulnerability.

    Fixed in 8.12.2+dfsg+~cs3.2.3-2
  6. Upgrade

    Upgrade undici to a version that resolves this vulnerability.

    Fixed in 6.29.1
  7. Upgrade

    Upgrade undici to a version that resolves this vulnerability.

    Fixed in 7.30.1
  8. Upgrade

    Upgrade undici to a version that resolves this vulnerability.

    Fixed in 8.12.2
  9. Configuration

    Restrict outbound connections to TLS 1.3 by setting connect: { minVersion: 'TLSv1.3', maxVersion: 'TLSv1.3' }, when the target endpoints support TLS 1.3.

    undici client or agent connect.minVersion and connect.maxVersion = TLSv1.3

Event History

Oct 15, 2026
CVE Published
via MITRE·06:38 PM
Data Sourced
via MITRE·06:38 PM
DescriptionSeverityWeakness
Data Sourced
via Red Hat·06:45 PM
DescriptionSeverityAffected Software
Data Sourced
via OSV·07:17 PM
Affected Software
Data Sourced
via NVD·07:17 PM
DescriptionSeverityWeaknessAffected Software
Oct 27, 2026
Advisory Published
via GitHub·07:02 PM
Data Sourced
via GitHub·07:02 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this denial-of-service condition?

Applications using undici versions 4.2.1 through 6.29.0, 7.0.0 through 7.30.0, or 8.0.0 through 8.12.1 are affected. This includes applications that reach HTTPS endpoints through undici directly or through Node.js global fetch().

2

What must an attacker control to crash the process?

The attacker must control or compromise an HTTPS endpoint that the application connects to and perform a server-initiated TLS 1.2 renegotiation using a different CA-trusted certificate whose hostname does not match the requested host. No CA compromise, client credentials, or user interaction is required.

3

Is the issue limited to a particular HTTP protocol or TLS version?

Both the HTTP/1.1 and HTTP/2 paths are affected. Only TLS 1.2 is vulnerable because TLS 1.3 does not support renegotiation.

4

What versions contain the fix?

Upgrade to undici 6.29.1, 7.30.1, or 8.12.2, as appropriate for the major version in use. The vulnerable behavior can terminate the Node.js process and interrupt all in-flight requests and background work.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203