CVE-2026-93675: Langflow OSS is affected by multiple vulnerabilities
Published Oct 2, 2026
·Updated
IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote attacker to execute arbitrary code due to an expected dependency confusion.
Other sources
Langflow OSS could allow a remote attacker to execute arbitrary code due to an expected dependency confusion.
— IBM
Affected Software
2 affected components
IBM Langflow OSS<=1.0.0-1.12.2
Langflow Langflow>=1.0.0<1.12.3
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
IBM Langflow OSSto a version that resolves this vulnerability.Fixed in 1.12.3
Event History
Oct 2, 2026
CVE Published
via IBM·12:00 AM
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software
Oct 7, 2026
CVE Published
via MITRE·12:01 AM
Data Sourced
via MITRE·12:01 AM
RemedyDescriptionSeverityWeakness
Data Sourced
via NVD·01:16 AM
DescriptionSeverityWeaknessAffected Software
Frequently Asked Questions
1
Does exploitation require an authenticated account or user interaction?
The CVSS vector indicates that no privileges are required, but user interaction is required. The attack vector is network-based and has low attack complexity.
2
Which releases are identified as affected?
IBM Langflow OSS versions 1.0.0 through 1.12.2 are identified as affected.