CVE-2026-94245: Wallet System for WooCommerce 2.0.0 - 2.7.10 - Subscriber+ Arbitrary Wallet Balance Theft via IDOR
The Wallet System for WooCommerce WordPress plugin before 2.8.0 does not verify that the user submitting a wallet transfer owns the wallet being debited, allowing any authenticated user, including one with only the Subscriber role, to move an arbitrary user's wallet balance, including an administrator's, into an account they control.
Affected Software
Event History
Frequently Asked Questions
Who can exploit this issue?
Any authenticated user can exploit it, including users with only the Subscriber role. The attacker does not need administrator privileges or user interaction.
What does an attacker need to do to steal funds?
The attacker needs an account on the affected WordPress site and must submit a wallet transfer that identifies a wallet they do not own as the source. They can transfer that balance into an account they control, including by debiting an administrator's wallet.
Which versions need remediation?
Versions before 2.8.0 are affected, including 2.0.0 through 2.7.10. Upgrade to version 2.8.0 or later.