CVE-2026-95101: NGINX ngx_http_v3_module vulnerability

Published Oct 14, 2026
·
Updated

Description NGINX Plus and NGINX Open Source have a vulnerability in the ngxhttpv3module module. When using HTTP/3 with proxyrequestbuffering on directive, an unauthenticated attacker may be able to inject data in the proxied request. Impact This vulnerability may allow remote attackers to inject data in the proxied request.  There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Affected Software

19 affected componentsFixes available
Nginx NGINX Plus
Nginx NGINX Open Source
debian/nginx<=1.22.1-9+deb12u9, <=1.22.1-9+deb12u10, <=1.26.3-3+deb13u7
1.26.3-3+deb13u101.30.6-2
F5 NGINX Plus>=37.1.0<=37.1.1, >=37.0.0<=37.0.6
37.2.0.137.0.7.1
F5 NGINX Plus=33
F5 NGINX Open Source>=1.31.0<=1.31.6, >=1.30.0<=1.30.5, >=1.25.0<=1.28.3
1.31.71.30.6
F5 NGINX Instance Manager>=2.18.0<=2.23.0
2.24.0
F5 F5 WAF for NGINX=5.15.0, >=5.9.0<=5.14.1
5.16.05.14.2
F5 F5 DoS for NGINX>=4.8.0<=4.10.0
4.11.0
F5 NGINX Gateway Fabric>=2.1.0<=2.7.2
2.8.0
F5 NGINX Gateway Fabric>=1.5.0<=1.6.2
F5 NGINX Ingress Controller>=3<=2026, =2026
F5 NGINX Ingress Controller>=5.0.0<=5.6.3
5.7.0
F5 NGINX Ingress Controller>=4.0.0<=4.0.1
F5 NGINX Ingress Controller>=3.7.1<=3.7.2
ubuntu/nginx<1.30.4-7ubuntu1.1
1.30.4-7ubuntu1.1
ubuntu/nginx<1.28.3-2ubuntu1.12
1.28.3-2ubuntu1.12
All of the following
azurelinux/nginx<1.30.6-1
1.30.6-1
Microsoft Azure Linux=3.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/nginx to a version that resolves this vulnerability.

    Fixed in 1.26.3-3+deb13u10Fixed in 1.30.6-2
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 37.2.0.137.0.7.1
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 1.31.71.30.6
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.24.0
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.16.05.14.2
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 4.11.0
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.8.0
  8. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.7.0
  9. Upgrade

    Upgrade ubuntu/nginx to a version that resolves this vulnerability.

    Fixed in 1.30.4-7ubuntu1.1
  10. Upgrade

    Upgrade ubuntu/nginx to a version that resolves this vulnerability.

    Fixed in 1.28.3-2ubuntu1.12
  11. Upgrade

    Upgrade azurelinux/nginx to a version that resolves this vulnerability.

    Fixed in 1.30.6-1

Event History

Oct 14, 2026
Advisory Published
via F5·01:41 PM
Data Sourced
via F5·01:41 PM
DescriptionSeverityWeaknessAffected Software
CVE Published
via MITRE·02:40 PM
Data Sourced
via MITRE·02:40 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:17 PM
DescriptionSeverityWeakness
Oct 15, 2026
Data Sourced
via OSV·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Oct 17, 2026
Data Sourced
via Microsoft·08:07 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

Which deployments are exposed?

Deployments of F5 NGINX Plus or F5 NGINX Open Source are exposed when they use the ngx_http_v3_module with HTTP/3 and have the proxy_request_buffering directive enabled.

2

Does exploitation require authentication or user interaction?

No. The vulnerability is described as exploitable by an unauthenticated remote attacker and does not require user interaction.

3

Is the management or control plane affected?

No. The issue is limited to the data plane; no control plane exposure is identified.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203