CVE-2026-97205: NGINX ngx_http_core_module vulnerability

Published Oct 14, 2026
·
Updated

NGINX ngxhttpcoremodule vulnerability

Other sources

NGINX Plus and NGINX Open Source have a vulnerability in the ngxhttpcoremodule module. When asynchronous file I/O (AIO) is enabled in certain configurations, processing a Server Side Includes (SSI) page containing “include virtual” commands may trigger a Use-After-Free (UAF) in the NGINX worker process. This may cause memory corruption or a worker process crash. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system, corrupt its memory, or possibly trigger code execution. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

— Ubuntu

NGINX Plus and NGINX Open Source have a vulnerability in the ngxhttpcoremodule module. When asynchronous file I/O (AIO) is enabled in certain configurations, processing a Server Side Includes (SSI) page containing include virtual commands may trigger a Use-After-Free (UAF) in the NGINX worker process. This may cause memory corruption or cause a worker process to terminate unexpectedly. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.

— F5

Affected Software

18 affected componentsFixes available
Nginx NGINX Plus
Nginx NGINX Open Source
debian/nginx<=1.22.1-9+deb12u9, <=1.22.1-9+deb12u10, <=1.26.3-3+deb13u7
1.26.3-3+deb13u101.30.6-2
F5 NGINX Plus>=37.0.0<=37.0.4
37.1.0.137.0.5.1
F5 NGINX Plus=33
F5 NGINX Open Source>=1.31.0<=1.31.6, >=1.30.0<=1.30.5
1.31.71.30.6
F5 NGINX Instance Manager>=2.18.0<=2.23.0
2.24.0
F5 F5 WAF for NGINX>=5.9.0<=5.15.0
5.16.05.14.2
F5 NGINX App Protect WAF>=5.4.0<=5.8.0
F5 NGINX App Protect WAF>=4.12.0<=4.16.0
F5 F5 DoS for NGINX>=4.8.0<=4.10.0
4.11.0
F5 NGINX App Protect DoS>=4.5.0<=4.7.0
F5 NGINX Gateway Fabric>=2.1.0<=2.7.2
2.8.0
F5 NGINX Gateway Fabric
F5 NGINX Ingress Controller
F5 NGINX Ingress Controller>=5.6.0<=5.6.3
5.7.0
All of the following
azurelinux/nginx<1.30.6-1
1.30.6-1
Microsoft Azure Linux=3.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/nginx to a version that resolves this vulnerability.

    Fixed in 1.26.3-3+deb13u10Fixed in 1.30.6-2
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 37.1.0.137.0.5.1
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 1.31.71.30.6
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.24.0
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.16.05.14.2
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 4.11.0
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.8.0
  8. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.7.0
  9. Upgrade

    Upgrade azurelinux/nginx to a version that resolves this vulnerability.

    Fixed in 1.30.6-1

Event History

Oct 14, 2026
Advisory Published
via F5·01:33 PM
Data Sourced
via F5·01:33 PM
DescriptionSeverityWeaknessAffected Software
CVE Published
via MITRE·02:40 PM
Data Sourced
via MITRE·02:40 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·03:17 PM
DescriptionSeverityWeakness
Oct 15, 2026
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Oct 17, 2026
Data Sourced
via Microsoft·08:07 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

Which deployments are exposed to this issue?

NGINX Plus and NGINX Open Source deployments are affected when asynchronous file I/O is enabled in a susceptible configuration and SSI pages containing “include virtual” commands are processed. The issue affects the data plane only; there is no control-plane exposure.

2

What does an attacker need to exploit it?

An attacker must be able to trigger processing of an SSI page that contains “include virtual” commands in a deployment where AIO is enabled in the relevant configuration. No authentication or user interaction is required according to the supplied vector.

3

What is the likely impact if exploitation succeeds?

Exploitation may crash an NGINX worker process, corrupt memory, or cause denial of service. Code execution may be possible where ASLR is disabled or the attacker can bypass ASLR.

4

What should teams check while evaluating exposure?

Check whether AIO is enabled and whether the server processes SSI content containing “include virtual” commands. Also determine whether ASLR is disabled, since that increases the stated code-execution risk.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203