DEBIAN-CVE-2026-57184: Medium severity debian/asterisk vulnerability
Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, insufficient bounds checking in the chanooh323 Q.931 information-element parser permits an out-of-bounds read that may allow an unauthenticated attacker to crash Asterisk using carefully crafted setup packets. The chanooh323 addon channel driver must be explicitly compiled and installed, which is not the default, and its port must be publicly reachable. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/asteriskto a version that resolves this vulnerability.Fixed in 1:22.10.1+dfsg+~cs6.17.60671434-1 - Upgrade
Upgrade
Asterisk 20to a version that resolves this vulnerability.Fixed in 20.20.1 - Upgrade
Upgrade
Asterisk 21to a version that resolves this vulnerability.Fixed in 21.12.3 - Upgrade
Upgrade
Asterisk 22to a version that resolves this vulnerability.Fixed in 22.10.1 - Upgrade
Upgrade
Asterisk 23to a version that resolves this vulnerability.Fixed in 23.4.1 - Upgrade
Upgrade
Certified Asterisk 20to a version that resolves this vulnerability.Fixed in 20.7-cert11 - Upgrade
Upgrade
Certified Asterisk 22to a version that resolves this vulnerability.Fixed in 22.8-cert3