DRUPAL-CONTRIB-2026-268: Composer/drupal/ai vulnerability

Published Oct 28, 2026
·
Updated

This module enables you to use AI on the website. It also enables you to interact with AI providers.

The module does not sufficiently validate links under certain conditions, potentially allowing the exfiltration of sensitive information to external sites.

This vulnerability is mitigated by the fact that an attacker must use untrusted sources when interacting with the AI module in a way that produces rendered HTML.

Affected Software

2 affected componentsFixes available
composer/drupal/ai<1.4.11
1.4.11
composer/drupal/ai>=1.5.0<1.5.2
1.5.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/drupal/ai to a version that resolves this vulnerability.

    Fixed in 1.4.11
  2. Upgrade

    Upgrade composer/drupal/ai to a version that resolves this vulnerability.

    Fixed in 1.5.2

Event History

Oct 28, 2026
Advisory Published
via OSV·05:09 PM
Data Sourced
via OSV·05:09 PM
DescriptionAffected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203