F5-K000162416: Buffer Overflow

Published Oct 14, 2026
·
Updated

A vulnerability exists in NGINX Plus and NGINX Open Source when a location is configured that uses the alias directive together with rewrite and a set or return directive referencing the $requestfilename variable. Alternatively, the same result could be achieved when the $requestfilename variable is used in an access logformat directive. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.

Affected Software

14 affected componentsFixes available
F5 NGINX Plus>=37.0.0<=37.0.4
37.0.5.1
F5 NGINX Plus=33
F5 NGINX Open Source>=1.31.0<=1.31.6, >=1.0.0<=1.30.5
1.31.71.30.6
F5 NGINX Open Source>=0.1.29<=0.9.9
F5 NGINX Instance Manager>=2.18.0<=2.23.0
2.24.0
F5 F5 WAF for NGINX>=5.9.0<=5.15.0
5.16.05.14.2
F5 NGINX App Protect WAF>=5.4.0<=5.8.0
F5 NGINX App Protect WAF>=4.12.0<=4.16.0
F5 F5 DoS for NGINX>=4.8.0<=4.10.0
4.11.0
F5 NGINX App Protect DoS>=4.5.0<=4.7.0
F5 NGINX Gateway Fabric>=2.1.0<=2.7.2
2.8.0
F5 NGINX Gateway Fabric
F5 NGINX Ingress Controller
F5 NGINX Ingress Controller>=5.6.0<=5.6.3
5.7.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 37.0.5.1
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 1.31.71.30.6
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.24.0
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.16.05.14.2
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 4.11.0
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.8.0
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.7.0

Event History

Oct 14, 2026
Advisory Published
via F5·01:32 PM
Data Sourced
via F5·01:32 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this issue?

Exposure depends on configuration, not merely product presence. Affected deployments use a location that combines alias with rewrite and a set or return directive referencing $request_filename, or use $request_filename in an access log_format directive.

2

Does exploitation require authentication or user interaction?

No. The issue can be triggered by an unauthenticated attacker sending crafted HTTP requests, and it does not require user interaction.

3

What conditions affect exploitability?

Exploitation requires additional conditions beyond the attacker's control. Code execution is possible only where ASLR is disabled or the attacker can bypass ASLR.

4

What is the likely operational impact if an attack succeeds?

The crafted request can cause a heap buffer overflow in an NGINX worker process, leading to a worker restart. Under the stated ASLR conditions, the issue can also result in code execution.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203