F5-K000162608: Use After Free

Published Oct 14, 2026
·
Updated

NGINX Plus and NGINX Open Source have a vulnerability in the ngxhttpcoremodule module. When asynchronous file I/O (AIO) is enabled in certain configurations, processing a Server Side Includes (SSI) page containing include virtual commands may trigger a Use-After-Free (UAF) in the NGINX worker process. This may cause memory corruption or cause a worker process to terminate unexpectedly. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.

Affected Software

13 affected componentsFixes available
F5 NGINX Plus>=37.0.0<=37.0.4
37.1.0.137.0.5.1
F5 NGINX Plus=33
F5 NGINX Open Source>=1.31.0<=1.31.6, >=1.30.0<=1.30.5
1.31.71.30.6
F5 NGINX Instance Manager>=2.18.0<=2.23.0
2.24.0
F5 F5 WAF for NGINX>=5.9.0<=5.15.0
5.16.05.14.2
F5 NGINX App Protect WAF>=5.4.0<=5.8.0
F5 NGINX App Protect WAF>=4.12.0<=4.16.0
F5 F5 DoS for NGINX>=4.8.0<=4.10.0
4.11.0
F5 NGINX App Protect DoS>=4.5.0<=4.7.0
F5 NGINX Gateway Fabric>=2.1.0<=2.7.2
2.8.0
F5 NGINX Gateway Fabric
F5 NGINX Ingress Controller
F5 NGINX Ingress Controller>=5.6.0<=5.6.3
5.7.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 37.1.0.137.0.5.1
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 1.31.71.30.6
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.24.0
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.16.05.14.2
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 4.11.0
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.8.0
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.7.0

Event History

Oct 14, 2026
Advisory Published
via F5·01:33 PM
Data Sourced
via F5·01:33 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What conditions are needed for exploitation?

The affected NGINX instance must have asynchronous file I/O (AIO) enabled in a susceptible configuration and process an SSI page containing include virtual commands. No authentication or user interaction is required according to the supplied attack vector.

2

Who is exposed to code execution versus worker-process termination?

Memory corruption or an unexpected worker-process termination may occur when the vulnerable request path is triggered. Code execution is described for systems with ASLR disabled, or where an attacker can bypass ASLR.

3

Are all NGINX deployments affected by default?

The issue is conditional on AIO being enabled in certain configurations and on processing SSI content with include virtual commands. The supplied information does not establish that default configurations are affected.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203