GHSA-2v3c-qxhr-7vpv: Composer/symfony/yaml vulnerability

Published Oct 27, 2026
·
Updated

Description

Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error.

Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installed and the endpoint does not restrict acceptFormat: a single unauthenticated request with a YAML content type is enough.

Resolution

The inline lexer now enters and leaves the same nesting level as the rest of the parser, so nested inline collections are bounded by maxNestingLevel, and the parser raises a ParseException beyond it.

The patches for this issue are available here for branch 5.4 (and forward-ported to 6.4, 7.4, 8.1 and 8.2).

Credits

We would like to thank Nicolas Grekas for reporting the issue and providing the fix.

References

- Fix: #65688

Affected Software

8 affected componentsFixes available
composer/symfony/yaml>=8.0.0<8.1.6
8.1.6
composer/symfony/yaml>=7.0.0<7.4.18
7.4.18
composer/symfony/yaml>=6.0.0<6.4.45
6.4.45
composer/symfony/yaml>=2.0.0<5.4.54
5.4.54
composer/symfony/symfony>=8.0.0<8.1.6
8.1.6
composer/symfony/symfony>=7.0.0<7.4.18
7.4.18
composer/symfony/symfony>=6.0.0<6.4.45
6.4.45
composer/symfony/symfony>=2.0.0<5.4.54
5.4.54

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/symfony/yaml to a version that resolves this vulnerability.

    Fixed in 8.1.6
  2. Upgrade

    Upgrade composer/symfony/yaml to a version that resolves this vulnerability.

    Fixed in 7.4.18
  3. Upgrade

    Upgrade composer/symfony/yaml to a version that resolves this vulnerability.

    Fixed in 6.4.45
  4. Upgrade

    Upgrade composer/symfony/yaml to a version that resolves this vulnerability.

    Fixed in 5.4.54
  5. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 8.1.6
  6. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 7.4.18
  7. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 6.4.45
  8. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 5.4.54
  9. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Patch #65688

Event History

Oct 27, 2026
Advisory Published
via GitHub·07:01 PM
Data Sourced
via GitHub·07:01 PM
DescriptionWeaknessAffected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203