GHSA-3fx2-cqw9-xr3c: Path Traversal
Summary
The LangGraph Python SDK v3 streaming client interpolates caller-supplied threadid and assistantid values into request paths without encoding them at four synchronous and asynchronous call sites. Relative path segments can therefore redirect an authenticated GET request to another path on the same configured server.
Details
The affected gettree and fetchstate implementations build request paths from raw identifiers rather than passing each identifier through the SDK's existing quotepathparam helper. HTTP path normalization can collapse values containing relative segments before dispatch while retaining the client's authentication headers.
langgraph-sdk versions 0.4.0 through 0.4.5 are affected. The v3 stream module is not present in the 0.3.x release line.
RemoteGraph v3 streaming in langgraph 1.2.3 and later is also affected when used with a vulnerable langgraph-sdk version. It passes config["configurable"]["threadid"] into threads.stream(...), and its dependency range permits affected SDK versions.
Impact
An application is affected only if it passes attacker-controlled text as a streaming threadid or assistantid. In that configuration, an attacker may select another readable path on the configured server and cause the SDK to return that response to the application. Through threadid, the attacker can also control the query string, for example by targeting /store/items?namespace=...&key=...; assistantid controls only the path. The affected requests are GET operations, so this issue does not provide a write primitive.
The LangGraph Platform is not exposed to this issue.
Remediation
Upgrade langgraph-sdk to version 0.4.6 or later. The fix encodes assistantid in gettree and threadid in fetchstate with quotepathparam in both synchronous and asynchronous stream modules.
If you use RemoteGraph, also upgrade langgraph to version 1.2.14 or later, which requires langgraph-sdk>=0.4.6.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
pip/langgraphto a version that resolves this vulnerability.Fixed in 1.2.14 - Upgrade
Upgrade
pip/langgraph-sdkto a version that resolves this vulnerability.Fixed in 0.4.6 - Upgrade
Upgrade
langgraph-sdkto a version that resolves this vulnerability.Fixed in 0.4.6 - Upgrade
Upgrade
langgraphto a version that resolves this vulnerability.Fixed in 1.2.14
Event History
Frequently Asked Questions
Which deployments are actually exposed?
An application is affected only if it passes attacker-controlled text as a streaming thread_id or assistant_id. The vulnerable code is in the LangGraph Python SDK v3 streaming client; the v3 stream module is not present in the 0.3.x release line.
What does an attacker need to exploit this?
The attacker must be able to control a thread_id or assistant_id used by the streaming client. A low-privileged caller is sufficient, and no user interaction is required; relative path segments in those values can alter the destination path of an authenticated GET request on the configured server.
Are RemoteGraph users affected?
RemoteGraph v3 streaming in langgraph 1.2.3 and later is affected when it uses a vulnerable langgraph-sdk version. It forwards config["configurable"]["thread_id"] to threads.stream(...), and its dependency range allows affected SDK releases.
Which langgraph-sdk versions should be treated as vulnerable?
langgraph-sdk versions 0.4.0 through 0.4.5 are affected. The advisory does not identify a fixed version in the provided data.