GHSA-65hg-cf3f-5m39: XSS

Published Oct 28, 2026
·
Updated

Impact When the HTML text parser cannot obtain a document from DOMParser because the call throws, it falls back to assigning the raw markup to the innerHTML of an element created in the hosting document, and the allow-list is applied only to the resulting DOM afterwards. In Chromium the Trusted Types policy callback that the parser uses throws while a beforeprint handler is running, so if the hosting page re-renders the chart from a beforeprint handler, every HTML-rendered text option parsed at that moment, such as useHTML titles, axis labels and data labels or text set by responsive rules, is inserted unsanitized, and event handlers embedded in that markup run in the origin of the page hosting the chart. Exploitation requires that untrusted data reach the chart configuration, that the hosting page update the chart from a beforeprint handler in Chromium, and that printing be started, which the print item of the exporting menu does on its own. Charts built with Highcharts Stock, Maps and Gantt are included, since those ship from the same package as Core.

Workarounds Drop-in fix - for any versions affected (12.0.0-13.0.2). Add the below IIFE to run after Highcharts is loaded. ((n)=>{n.AST.prototype.parseMarkup=function parseMarkup(t){let e,i=[];t=t.trim().replace(/ style=(["'])/g," data-style=$1");try{e=new DOMParser().parseFromString(tI?tI.createHTML(t):t,"text/html")}catch{}if(!e)try{e=new DOMParser().parseFromString(t,"text/html")}catch{}e||((e=n.doc.implementation.createHTMLDocument("")).body.innerHTML=t);let s=(t,e)=>{let i=t.localName||t.nodeName.toLowerCase(),o={tagName:i};"#text"===i&&(o.textContent=t.textContent||"");let r=t.attributes;if(r){let t={};[].forEach.call(r,e=>{"data-style"===e.name?o.style=tB.parseStyle(e.value):t[e.name]=e.value}),o.attributes=t}if(t.childNodes.length){let e=[];[].forEach.call(t.childNodes,t=>{s(t,e)}),e.length&&(o.children=e)}e.push(o)};return[].forEach.call(e.body.childNodes,t=>s(t,i)),i};})(Highcharts); Live demo & testing

Obtaining the patched version The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install highcharts@13.1.0. If you load Highcharts from the CDN, use the versioned URLs on code.highcharts.com, for example https://code.highcharts.com/13.1.0/highcharts.js. For more on each installation method, see the installation guide.

Affected Software

2 affected componentsFixes available
npm/highcharts>=13.0.0<=13.0.2
13.1.0
npm/highcharts>=12.0.0<12.6.1
12.6.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade npm/highcharts to a version that resolves this vulnerability.

    Fixed in 13.1.0
  2. Upgrade

    Upgrade npm/highcharts to a version that resolves this vulnerability.

    Fixed in 12.6.1
  3. Upgrade

    Upgrade highcharts to a version that resolves this vulnerability.

    Fixed in 13.1.0
  4. Compensating control

    For affected Highcharts versions 12.0.0–13.0.2, add the provided parseMarkup IIFE immediately after Highcharts is loaded as a drop-in workaround.

Event History

Oct 28, 2026
Advisory Published
via GitHub·07:55 PM
Data Sourced
via GitHub·07:55 PM
DescriptionWeaknessAffected Software

Frequently Asked Questions

1

Which deployments are actually exposed to this issue?

Exposure requires Highcharts versions 12.0.0 through 13.0.2 running in Chromium, with untrusted input reaching HTML-rendered chart text options such as useHTML titles, axis labels, data labels, or text supplied through responsive rules. Highcharts Stock, Maps, and Gantt are also included because they ship from the same package as Core.

2

What conditions must an attacker trigger for exploitation?

The hosting page must re-render or update the chart from a beforeprint handler, and printing must be started. The exporting menu's print item can initiate printing, after which event handlers embedded in untrusted HTML markup may execute in the hosting page's origin.

3

Is there a mitigation if upgrading cannot happen immediately?

A drop-in fix is available for all affected versions, 12.0.0 through 13.0.2. The advisory describes it as an IIFE that must run after Highcharts, but the provided data does not include the code.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203