Advisory Published


First published: Mon Nov 20 2023(Updated: )

### Impact The Solr-based search suggestion provider that also duplicates as generic JavaScript API for search results in XWiki exposes the content of all documents of all wikis to anybody who has access to it, by default it is public. This exposes all information stored in the wiki (but not some protected information like password hashes). While there is a right check normally, the right check can be circumvented by explicitly requesting fields from Solr that don't include the data for the right check. This can be reproduced by opening `<xwiki-server>/xwiki/bin/get/XWiki/SuggestSolrService?outputSyntax=plain&media=json&nb=1000&query=q%3D*%3A*%0Aq.op%3DAND%0Afq%3Dtype%3ADOCUMENT%0Afl%3Dtitle_%2C+reference%2C+links%2C+doccontentraw_%2C+objcontent__&input=+` where `<xwiki-server>` is the URL of the XWiki installation. If this displays any results, the wiki is vulnerable. ### Patches This has been fixed in XWiki 15.6RC1, 15.5.1 and 14.10.15 by not listing documents whose rights cannot be checked. ### Workarounds We're not aware of a workaround apart from upgrading to a fixed version. ### References * https://jira.xwiki.org/browse/XWIKI-21138 * https://github.com/xwiki/xwiki-platform/commit/93b8ec702d7075f0f5794bb05dfb651382596764

Affected SoftwareAffected VersionHow to fix

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is the impact of GHSA-7fqr-97j7-jgf4?

    The vulnerability exposes the content of all documents of all wikis to anyone who has access to it, potentially exposing sensitive information stored in the wiki.

  • What software is affected by GHSA-7fqr-97j7-jgf4?

    The vulnerability affects versions 15.0-rc-1 to 15.5.1 of org.xwiki.platform:xwiki-platform-search-solr-query and versions 6.3-milestone-2 to 14.10.15 of org.xwiki.platform:xwiki-platform-search-solr-query.

  • What is the severity of GHSA-7fqr-97j7-jgf4?

    The severity of the vulnerability is high with a CVSS score of 7.5.

  • What is the CWE ID of GHSA-7fqr-97j7-jgf4?

    The CWE ID for this vulnerability is 285.

  • How can I fix GHSA-7fqr-97j7-jgf4?

    Upgrade to a version of org.xwiki.platform:xwiki-platform-search-solr-query that is equal to or newer than 15.5.1, or equal to or newer than 14.10.15 for versions prior to 15.0-rc-1.


SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203