Advisory Published


First published: Tue Nov 14 2023(Updated: )

Cross Site Scripting vulnerability in BootBox Bootbox.js v.3.2 through 6.0 allows a remote attacker to execute arbitrary code via a crafted payload to alert(), confirm(), prompt() functions.

Affected SoftwareAffected VersionHow to fix

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is the vulnerability ID of this vulnerability?

    The vulnerability ID for this vulnerability is GHSA-m4ch-4m5f-2gp6.

  • What is the severity of this vulnerability?

    The severity of this vulnerability is medium.

  • What software is affected by this vulnerability?

    The software affected by this vulnerability is BootBox Bootbox.js v.3.2 through 6.0.

  • How can an attacker exploit this vulnerability?

    An attacker can exploit this vulnerability by executing arbitrary code via a crafted payload to the alert(), confirm(), and prompt() functions.

  • Is there a fix available for this vulnerability?

    Yes, a fix is available for this vulnerability. It is recommended to update to a version higher than 6.0.0 of Bootbox.js.


SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2023 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203