GHSA-mgpr-56r4-5c67: n8n before 1.123.85, 2.43.5, and 2.44.1 OData $filter Injection via Outlook and SharePoint Nodes

Published Oct 28, 2026
·
Updated

n8n before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 contains an OData $filter injection vulnerability in the Microsoft Outlook contact lookup and Microsoft SharePoint v1 item update nodes, which build $filter string literals from expression-bindable parameters without escaping. Attackers who supply untrusted input to such workflows can inject single quotes to dump the bound mailbox's entire contact list or redirect SharePoint writes onto unintended list items within the stored credential's scope.

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade n8n to a version that resolves this vulnerability.

    Fixed in 1.123.85
  2. Upgrade

    Upgrade n8n to a version that resolves this vulnerability.

    Fixed in 2.43.5
  3. Upgrade

    Upgrade n8n to a version that resolves this vulnerability.

    Fixed in 2.44.1

Event History

Oct 28, 2026
CVE Published
via OSV·06:59 PM
Data Sourced
via OSV·06:59 PM
DescriptionSeverityWeakness

Frequently Asked Questions

1

Who is exposed to this issue?

Deployments are exposed if they run a version before 1.123.85, a 2.x version before 2.43.5, or a 2.44.x version before 2.44.1 and use the affected Microsoft Outlook contact lookup or Microsoft SharePoint v1 item update nodes with expression-bindable parameters influenced by untrusted input.

2

What does an attacker need to exploit it?

An attacker needs to be able to supply untrusted input to a workflow that passes that input into the affected expression-bindable parameters. They can use injected single quotes in OData $filter values.

3

What can exploitation allow?

In Outlook contact lookup workflows, exploitation can dump the entire contact list for the mailbox associated with the stored credential. In SharePoint v1 item update workflows, it can redirect writes to unintended list items within the scope of the stored credential.

4

What versions address the issue?

Upgrade to 1.123.85 or later for the 1.x branch, 2.43.5 or later for applicable 2.x releases, or 2.44.1 or later for the 2.44.x branch.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203