GHSA-r5wg-q8fc-p6w2: XSS

Published Oct 28, 2026
·
Updated

Impact The pagination language strings are written into the DOM as markup rather than as text. An attacker who controls those language options can supply elements carrying event handlers, and those handlers execute in the origin of the page hosting the Grid when the pagination controls render. Exploitation requires that untrusted data reach the Grid language configuration and that pagination be enabled on the Grid.

Workarounds Run this once after loading the Grid, before creating any grid: javascript { const Pagination = Grid.Pagination;

const escapeLang = (pagination) => { const lang = pagination.lang; if (!lang) { return; }

for (const key of ['pageInfo', 'pageSizeLabel']) { if (typeof lang[key] === 'string') { lang[key] = lang[key].replace(/</g, '&lt;'); } } };

for (const name of ['updatePageInfo', 'renderPageSizeSelector']) { const original = Pagination.prototype[name];

Pagination.prototype[name] = function (...args) { escapeLang(this); return original.apply(this, args); }; } }

Obtaining the patched version The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/grid-lite@3.2.0. If you load Highcharts Grid from a CDN, use a versioned URL, for example https://cdn.jsdelivr.net/npm/@highcharts/grid-lite@3.2.0/grid-lite.js. For more on each installation method, see the installation guide.

Affected Software

2 affected componentsFixes available
npm/@highcharts/grid-pro>=2.0.0<=3.1.0
3.2.0
npm/@highcharts/grid-lite>=2.0.0<=3.1.0
3.2.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade npm/@highcharts/grid-pro to a version that resolves this vulnerability.

    Fixed in 3.2.0
  2. Upgrade

    Upgrade npm/@highcharts/grid-lite to a version that resolves this vulnerability.

    Fixed in 3.2.0
  3. Upgrade

    Upgrade @highcharts/grid-lite to a version that resolves this vulnerability.

    Fixed in 3.2.0
  4. Compensating control

    After loading Highcharts Grid and before creating any grid, run the provided workaround that overrides the pagination methods and escapes '<' in the pageInfo and pageSizeLabel language strings by replacing it with '&lt;'.

Event History

Oct 28, 2026
Advisory Published
via GitHub·07:57 PM
Data Sourced
via GitHub·07:57 PM
DescriptionWeaknessAffected Software

Frequently Asked Questions

1

Which deployments are exposed?

Deployments are exposed when pagination is enabled and untrusted data can reach the Grid language configuration. The affected packages listed are npm/@highcharts/grid-pro and npm/@highcharts/grid-lite.

2

What must an attacker control to exploit this issue?

An attacker must be able to supply language option values used by the Grid while pagination is enabled. Malicious markup with event handlers can then execute when the pagination controls render in the origin hosting the Grid.

3

What can be done if upgrading is not immediately possible?

Apply the provided runtime workaround after loading Grid and before creating any grids. It wraps the pagination rendering methods and escapes less-than characters in the pageInfo and pageSizeLabel language strings.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203