GHSA-rh54-vffm-5fvp: XSS

Published Oct 27, 2026
·
Updated

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.

The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.

Patches The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

For more information Email us at security@cksource.com if you have any questions or comments about this advisory.

Affected Software

4 affected componentsFixes available
npm/@ckeditor/ckeditor5-engine>=48.0.0<48.5.1
48.5.1
npm/ckeditor5>=48.0.0<48.5.1
48.5.1
npm/@ckeditor/ckeditor5-engine>=45.0.0<47.7.4
47.7.4
npm/ckeditor5>=45.0.0<47.7.4
47.7.4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade npm/@ckeditor/ckeditor5-engine to a version that resolves this vulnerability.

    Fixed in 48.5.1
  2. Upgrade

    Upgrade npm/ckeditor5 to a version that resolves this vulnerability.

    Fixed in 48.5.1
  3. Upgrade

    Upgrade npm/@ckeditor/ckeditor5-engine to a version that resolves this vulnerability.

    Fixed in 47.7.4
  4. Upgrade

    Upgrade npm/ckeditor5 to a version that resolves this vulnerability.

    Fixed in 47.7.4
  5. Upgrade

    Upgrade CKEditor 5 to a version that resolves this vulnerability.

    Fixed in 48.5.1
  6. Upgrade

    Upgrade CKEditor 5 to a version that resolves this vulnerability.

    Fixed in 47.7.4

Event History

Oct 27, 2026
Advisory Published
via GitHub·09:05 PM
Data Sourced
via GitHub·09:05 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What conditions are required for exploitation?

An attacker needs the editor to process incoming style attribute values. Successful exploitation can result in unauthorized JavaScript execution through the XSS vulnerability.

2

Which CKEditor 5 releases contain the fix?

The fix is available in CKEditor 5 version 48.5.1 and later, and in 47.7.4 for the LTS release line.

3

Which packages should be reviewed for exposure?

Review deployments using the npm packages @ckeditor/ckeditor5-engine and ckeditor5, particularly where the editor processes incoming style attribute values.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203