GO-2023-2402: Medium severity OpenSSH OpenSSH vulnerability
The SSH transport protocol with certain OpenSSH extensions, found in OpenSSH before 9.6 and other products, allows remote attackers to bypass integrity checks such that some packets are omitted (from the extension negotiation message), and a client and server may consequently end up with a connection for which some security features have been downgraded or disabled, aka a Terrapin attack. This occurs because the SSH Binary Packet Protocol (BPP), implemented by these extensions, mishandles the handshake phase and mishandles use of sequence numbers. For example, there is an effective attack against SSH's use of ChaCha20-Poly1305 (and CBC with Encrypt-then-MAC). The bypass occurs in chacha20-poly1305@openssh.com and (if CBC is used) the -etm@openssh.com MAC algorithms. This also affects Maverick Synergy Java SSH API before 3.1.0-SNAPSHOT, Dropbear through 2022.83, Ssh before 5.1.1 in Erlang/OTP, PuTTY before 0.80, AsyncSSH before 2.14.2, golang.org/x/crypto before 0.17.0, libssh before 0.10.6, libssh2 through 1.11.0, Thorn Tech SFTP Gateway before 3.4.6, Tera Term before 5.1, Paramiko before 3.4.0, jsch before 0.2.15, SFTPGo before 2.5.6, Netgate pfSense Plus through 23.09.1, Netgate pfSense CE through 2.7.2, HPN-SSH through 18.2.0, ProFTPD before 1.3.8b (and before 1.3.9rc2), ORYX CycloneSSH before 2.3.4, NetSarang XShell 7 before Build 0144, CrushFTP before 10.6.0, ConnectBot SSH library before 2.2.22, Apache MINA sshd through 2.11.0, sshj through 0.37.0, TinySSH through 20230101, trilead-ssh2 6401, LANCOM LCOS and LANconfig, FileZilla before 3.66.4, Nova before 11.8, PKIX-SSH before 14.4, SecureCRT before 9.4.3, Transmit5 before 5.10.4, Win32-OpenSSH before 9.5.0.0p1-Beta, WinSCP before 6.2.2, Bitvise SSH Server before 9.32, Bitvise SSH Client before 9.33, KiTTY through 0.76.1.13, the net-ssh gem 7.2.0 for Ruby, the mscdex ssh2 module before 1.15.0 for Node.js, the thrussh library before 0.35.1 for Rust, and the Russh crate before 0.40.2 for Rust.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
OpenSSHto a version that resolves this vulnerability.Fixed in 9.6 - Upgrade
Upgrade
Maverick Synergy Java SSH APIto a version that resolves this vulnerability.Fixed in 3.1.0-SNAPSHOT - Upgrade
Upgrade
PuTTYto a version that resolves this vulnerability.Fixed in 0.80 - Upgrade
Upgrade
AsyncSSHto a version that resolves this vulnerability.Fixed in 2.14.2 - Upgrade
Upgrade
golang.org/x/cryptoto a version that resolves this vulnerability.Fixed in 0.17.0 - Upgrade
Upgrade
libsshto a version that resolves this vulnerability.Fixed in 0.10.6 - Upgrade
Upgrade
Thorn Tech SFTP Gatewayto a version that resolves this vulnerability.Fixed in 3.4.6 - Upgrade
Upgrade
Tera Termto a version that resolves this vulnerability.Fixed in 5.1 - Upgrade
Upgrade
Paramikoto a version that resolves this vulnerability.Fixed in 3.4.0 - Upgrade
Upgrade
jschto a version that resolves this vulnerability.Fixed in 0.2.15 - Upgrade
Upgrade
SFTPGoto a version that resolves this vulnerability.Fixed in 2.5.6 - Upgrade
Upgrade
ProFTPDto a version that resolves this vulnerability.Fixed in 1.3.8b - Upgrade
Upgrade
ORYX CycloneSSHto a version that resolves this vulnerability.Fixed in 2.3.4 - Upgrade
Upgrade
NetSarang XShell 7to a version that resolves this vulnerability.Fixed in Build 0144 - Upgrade
Upgrade
CrushFTPto a version that resolves this vulnerability.Fixed in 10.6.0 - Upgrade
Upgrade
ConnectBot SSH libraryto a version that resolves this vulnerability.Fixed in 2.2.22 - Upgrade
Upgrade
FileZillato a version that resolves this vulnerability.Fixed in 3.66.4 - Upgrade
Upgrade
Novato a version that resolves this vulnerability.Fixed in 11.8 - Upgrade
Upgrade
PKIX-SSHto a version that resolves this vulnerability.Fixed in 14.4 - Upgrade
Upgrade
SecureCRTto a version that resolves this vulnerability.Fixed in 9.4.3 - Upgrade
Upgrade
Transmit5to a version that resolves this vulnerability.Fixed in 5.10.4 - Upgrade
Upgrade
Win32-OpenSSHto a version that resolves this vulnerability.Fixed in 9.5.0.0p1-Beta - Upgrade
Upgrade
WinSCPto a version that resolves this vulnerability.Fixed in 6.2.2 - Upgrade
Upgrade
Bitvise SSH Serverto a version that resolves this vulnerability.Fixed in 9.32 - Upgrade
Upgrade
Bitvise SSH Clientto a version that resolves this vulnerability.Fixed in 9.33 - Upgrade
Upgrade
mscdex ssh2 module for Node.jsto a version that resolves this vulnerability.Fixed in 1.15.0 - Upgrade
Upgrade
thrussh library for Rustto a version that resolves this vulnerability.Fixed in 0.35.1 - Upgrade
Upgrade
Russh crate for Rustto a version that resolves this vulnerability.Fixed in 0.40.2