OESA-2026-4602: python-brotlicffi security update
Python CFFI bindings to the Brotli library. Security Fix(es):
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.
Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.(CVE-2026-111497)
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
openeuler/python-brotlicffito a version that resolves this vulnerability.Fixed in 1.1.0.0-2.oe2403sp3 - Upgrade
Upgrade
python-brotlicffito a version that resolves this vulnerability.Fixed in 1.2.1