PKSA-nktx-f1n1-b4yd: Exponential and Quadratic Parse Times in the YAML Parser Let a Single Document Hold a Process
Published Nov 4, 2026
·Updated
Exponential and Quadratic Parse Times in the YAML Parser Let a Single Document Hold a Process
Affected Software
19 affected componentsFixes available
composer/symfony/yaml>=2.0.0, <3.0.0
composer/symfony/yaml>=3.0.0, <4.0.0
composer/symfony/yaml>=4.0.0, <5.0.0
composer/symfony/yaml>=5.0.0, <5.1.0
composer/symfony/yaml>=5.1.0, <5.2.0
composer/symfony/yaml>=5.2.0, <5.3.0
composer/symfony/yaml>=5.3.0, <5.4.0
composer/symfony/yaml>=5.4.0, <5.4.56
5.4.56
composer/symfony/yaml>=6.0.0, <6.1.0
composer/symfony/yaml>=6.1.0, <6.2.0
composer/symfony/yaml>=6.2.0, <6.3.0
composer/symfony/yaml>=6.3.0, <6.4.0
composer/symfony/yaml>=6.4.0, <6.4.50
6.4.50
composer/symfony/yaml>=7.0.0, <7.1.0
composer/symfony/yaml>=7.1.0, <7.2.0
composer/symfony/yaml>=7.3.0, <7.4.0
composer/symfony/yaml>=7.4.0, <7.4.23
7.4.23
composer/symfony/yaml>=8.0.0, <8.1.0
composer/symfony/yaml>=8.1.0, <8.1.11
8.1.11
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/symfony/yamlto a version that resolves this vulnerability.Fixed in 5.4.56 - Upgrade
Upgrade
composer/symfony/yamlto a version that resolves this vulnerability.Fixed in 6.4.50 - Upgrade
Upgrade
composer/symfony/yamlto a version that resolves this vulnerability.Fixed in 7.4.23 - Upgrade
Upgrade
composer/symfony/yamlto a version that resolves this vulnerability.Fixed in 8.1.11
Event History
Nov 4, 2026
Advisory Published
via Packagist·12:00 AM
Data Sourced
via Packagist·12:00 AM
DescriptionSeverityAffected Software