PKSA-nyd8-k74r-fsf2: DataUriNormalizer Opens Data URIs With a Non-Lowercase Scheme as Local Files, Letting a Client Read Any Server File
Published Nov 4, 2026
·Updated
DataUriNormalizer Opens Data URIs With a Non-Lowercase Scheme as Local Files, Letting a Client Read Any Server File
Affected Software
19 affected componentsFixes available
composer/symfony/serializer>=2.0.0, <3.0.0
composer/symfony/serializer>=3.0.0, <4.0.0
composer/symfony/serializer>=4.0.0, <5.0.0
composer/symfony/serializer>=5.0.0, <5.1.0
composer/symfony/serializer>=5.1.0, <5.2.0
composer/symfony/serializer>=5.2.0, <5.3.0
composer/symfony/serializer>=5.3.0, <5.4.0
composer/symfony/serializer>=5.4.0, <5.4.56
5.4.56
composer/symfony/serializer>=6.0.0, <6.1.0
composer/symfony/serializer>=6.1.0, <6.2.0
composer/symfony/serializer>=6.2.0, <6.3.0
composer/symfony/serializer>=6.3.0, <6.4.0
composer/symfony/serializer>=6.4.0, <6.4.50
6.4.50
composer/symfony/serializer>=7.0.0, <7.1.0
composer/symfony/serializer>=7.1.0, <7.2.0
composer/symfony/serializer>=7.3.0, <7.4.0
composer/symfony/serializer>=7.4.0, <7.4.23
7.4.23
composer/symfony/serializer>=8.0.0, <8.1.0
composer/symfony/serializer>=8.1.0, <8.1.11
8.1.11
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/symfony/serializerto a version that resolves this vulnerability.Fixed in 5.4.56 - Upgrade
Upgrade
composer/symfony/serializerto a version that resolves this vulnerability.Fixed in 6.4.50 - Upgrade
Upgrade
composer/symfony/serializerto a version that resolves this vulnerability.Fixed in 7.4.23 - Upgrade
Upgrade
composer/symfony/serializerto a version that resolves this vulnerability.Fixed in 8.1.11
Event History
Nov 4, 2026
Advisory Published
via Packagist·12:00 AM
Data Sourced
via Packagist·12:00 AM
DescriptionSeverityAffected Software