PYSEC-2026-1758: Medium severity OpenSSH OpenSSH vulnerability

Published Dec 18, 2023
·
Updated

The SSH transport protocol with certain OpenSSH extensions, found in OpenSSH before 9.6 and other products, allows remote attackers to bypass integrity checks such that some packets are omitted (from the extension negotiation message), and a client and server may consequently end up with a connection for which some security features have been downgraded or disabled, aka a Terrapin attack. This occurs because the SSH Binary Packet Protocol (BPP), implemented by these extensions, mishandles the handshake phase and mishandles use of sequence numbers. For example, there is an effective attack against SSH's use of ChaCha20-Poly1305 (and CBC with Encrypt-then-MAC). The bypass occurs in chacha20-poly1305@openssh.com and (if CBC is used) the -etm@openssh.com MAC algorithms. This also affects Maverick Synergy Java SSH API before 3.1.0-SNAPSHOT, Dropbear through 2022.83, Ssh before 5.1.1 in Erlang/OTP, PuTTY before 0.80, AsyncSSH before 2.14.2, golang.org/x/crypto before 0.17.0, libssh before 0.10.6, libssh2 through 1.11.0, Thorn Tech SFTP Gateway before 3.4.6, Tera Term before 5.1, Paramiko before 3.4.0, jsch before 0.2.15, SFTPGo before 2.5.6, Netgate pfSense Plus through 23.09.1, Netgate pfSense CE through 2.7.2, HPN-SSH through 18.2.0, ProFTPD before 1.3.8b (and before 1.3.9rc2), ORYX CycloneSSH before 2.3.4, NetSarang XShell 7 before Build 0144, CrushFTP before 10.6.0, ConnectBot SSH library before 2.2.22, Apache MINA sshd through 2.11.0, sshj through 0.37.0, TinySSH through 20230101, trilead-ssh2 6401, LANCOM LCOS and LANconfig, FileZilla before 3.66.4, Nova before 11.8, PKIX-SSH before 14.4, SecureCRT before 9.4.3, Transmit5 before 5.10.4, Win32-OpenSSH before 9.5.0.0p1-Beta, WinSCP before 6.2.2, Bitvise SSH Server before 9.32, Bitvise SSH Client before 9.33, KiTTY through 0.76.1.13, the net-ssh gem 7.2.0 for Ruby, the mscdex ssh2 module before 1.15.0 for Node.js, the thrussh library before 0.35.1 for Rust, and the Russh crate before 0.40.2 for Rust.

Affected Software

42 affected components
OpenSSH OpenSSH<9.6
Maverick Maverick Synergy Java SSH API<3.1.0-SNAPSHOT
Dropbear Dropbear<=2022.83
Erlang/OTP SSH<5.1.1
Putty PuTTY<0.80
pypi/asyncssh<2.14.2
go/golang.org/x/crypto<0.17.0
libssh libssh<0.10.6
libssh2 libssh2<=1.11.0
Thorn Tech SFTP Gateway<3.4.6
Tera Term Tera Term<5.1
pypi/paramiko<3.4.0
maven/jsch<0.2.15
SFTPGo SFTPGo<2.5.6
Netgate pfSense Plus<=23.09.1
Netgate pfSense CE<=2.7.2
HPN-SSH HPN-SSH<=18.2.0
ProFTPD ProFTPD<1.3.8b, <1.3.9rc2
ORYX CycloneSSH<2.3.4
NetSarang XShell 7<Build 0144
CrushFTP CrushFTP<10.6.0
ConnectBot ConnectBot SSH library<2.2.22
Apache MINA SSHD<=2.11.0
sshj sshj<=0.37.0
TinySSH TinySSH<=20230101
trilead trilead-ssh2
LANCOM LCOS
LANCOM LANconfig
FileZilla FileZilla<3.66.4
Nova Nova<11.8
PKIX-SSH PKIX-SSH<14.4
VanDyke Software SecureCRT<9.4.3
Panic Transmit 5<5.10.4
Microsoft Win32-OpenSSH<9.5.0.0p1-Beta
WinSCP WinSCP<6.2.2
Bitvise Bitvise SSH Server<9.32
Bitvise Bitvise SSH Client<9.33
Kitty Kitty<=0.76.1.13
rubygems/net-ssh
npm/ssh2<1.15.0
crates.io/thrussh<0.35.1
crates.io/russh<0.40.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade OpenSSH to a version that resolves this vulnerability.

    Fixed in 9.6
  2. Upgrade

    Upgrade Maverick Synergy Java SSH API to a version that resolves this vulnerability.

    Fixed in 3.1.0-SNAPSHOT
  3. Upgrade

    Upgrade Erlang/OTP Ssh to a version that resolves this vulnerability.

    Fixed in 5.1.1
  4. Upgrade

    Upgrade PuTTY to a version that resolves this vulnerability.

    Fixed in 0.80
  5. Upgrade

    Upgrade AsyncSSH to a version that resolves this vulnerability.

    Fixed in 2.14.2
  6. Upgrade

    Upgrade golang.org/x/crypto to a version that resolves this vulnerability.

    Fixed in 0.17.0
  7. Upgrade

    Upgrade libssh to a version that resolves this vulnerability.

    Fixed in 0.10.6
  8. Upgrade

    Upgrade Thorn Tech SFTP Gateway to a version that resolves this vulnerability.

    Fixed in 3.4.6
  9. Upgrade

    Upgrade Tera Term to a version that resolves this vulnerability.

    Fixed in 5.1
  10. Upgrade

    Upgrade Paramiko to a version that resolves this vulnerability.

    Fixed in 3.4.0
  11. Upgrade

    Upgrade jsch to a version that resolves this vulnerability.

    Fixed in 0.2.15
  12. Upgrade

    Upgrade SFTPGo to a version that resolves this vulnerability.

    Fixed in 2.5.6
  13. Upgrade

    Upgrade ProFTPD to a version that resolves this vulnerability.

    Fixed in 1.3.8b
  14. Upgrade

    Upgrade ProFTPD to a version that resolves this vulnerability.

    Fixed in 1.3.9rc2
  15. Upgrade

    Upgrade ORYX CycloneSSH to a version that resolves this vulnerability.

    Fixed in 2.3.4
  16. Upgrade

    Upgrade NetSarang XShell 7 to a version that resolves this vulnerability.

    Fixed in Build 0144
  17. Upgrade

    Upgrade CrushFTP to a version that resolves this vulnerability.

    Fixed in 10.6.0
  18. Upgrade

    Upgrade ConnectBot SSH library to a version that resolves this vulnerability.

    Fixed in 2.2.22
  19. Upgrade

    Upgrade FileZilla to a version that resolves this vulnerability.

    Fixed in 3.66.4
  20. Upgrade

    Upgrade Nova to a version that resolves this vulnerability.

    Fixed in 11.8
  21. Upgrade

    Upgrade PKIX-SSH to a version that resolves this vulnerability.

    Fixed in 14.4
  22. Upgrade

    Upgrade SecureCRT to a version that resolves this vulnerability.

    Fixed in 9.4.3
  23. Upgrade

    Upgrade Transmit5 to a version that resolves this vulnerability.

    Fixed in 5.10.4
  24. Upgrade

    Upgrade Win32-OpenSSH to a version that resolves this vulnerability.

    Fixed in 9.5.0.0p1-Beta
  25. Upgrade

    Upgrade WinSCP to a version that resolves this vulnerability.

    Fixed in 6.2.2
  26. Upgrade

    Upgrade Bitvise SSH Server to a version that resolves this vulnerability.

    Fixed in 9.32
  27. Upgrade

    Upgrade Bitvise SSH Client to a version that resolves this vulnerability.

    Fixed in 9.33
  28. Upgrade

    Upgrade mscdex ssh2 module for Node.js to a version that resolves this vulnerability.

    Fixed in 1.15.0
  29. Upgrade

    Upgrade thrussh library for Rust to a version that resolves this vulnerability.

    Fixed in 0.35.1
  30. Upgrade

    Upgrade Russh crate for Rust to a version that resolves this vulnerability.

    Fixed in 0.40.2

Event History

Dec 18, 2023
CVE Published
via OSV·12:00 AM
Data Sourced
via OSV·12:00 AM
DescriptionSeverity

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203