REDHAT-BUG-2128146: XSS
Severity/Risk: Serious Versions affected: 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions Versions fixed: 4.0.4, 3.11.10 and 3.9.17 Reported by: Adam Roberts, NCC Group CVE identifier: CVE-2022-40313 Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-68066 Tracker issue: MDL-68066 Stored XSS and page denial of service risks due to recursive rendering in Mustache template helpers
Affected Software
Event History
Frequently Asked Questions
What is the severity of REDHAT-BUG-2128146?
The severity of REDHAT-BUG-2128146 is classified as serious.
Which versions of Moodle are affected by REDHAT-BUG-2128146?
Moodle versions affected by REDHAT-BUG-2128146 include 4.0 to 4.0.3, 3.11 to 3.11.9, and 3.9 to 3.9.16.
What are the fixed versions for REDHAT-BUG-2128146?
The fixed versions for REDHAT-BUG-2128146 are 4.0.4, 3.11.10, and 3.9.17.
How do I fix REDHAT-BUG-2128146?
To fix REDHAT-BUG-2128146, update your Moodle installation to the patched versions.
Who reported the vulnerability REDHAT-BUG-2128146?
The vulnerability REDHAT-BUG-2128146 was reported by Adam Roberts from NCC Group.