REDHAT-BUG-2128147: High severity moodle vulnerability
Severity/Risk: Serious Versions affected: 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions Versions fixed: 4.0.4, 3.11.10 and 3.9.17 Reported by: Paul Holden CVE identifier: CVE-2022-40314 Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-75405 Tracker issue: MDL-75405 Remote code execution risk when restoring malformed backup file from Moodle 1.9
Affected Software
Event History
Frequently Asked Questions
What is the severity of REDHAT-BUG-2128147?
The severity of REDHAT-BUG-2128147 is classified as Serious.
Which versions of Moodle are affected by REDHAT-BUG-2128147?
Moodle versions affected by REDHAT-BUG-2128147 include 4.0 to 4.0.3, 3.11 to 3.11.9, and 3.9 to 3.9.16.
How do I fix REDHAT-BUG-2128147?
To resolve REDHAT-BUG-2128147, upgrade to Moodle versions 4.0.4, 3.11.10, or 3.9.17.
Is REDHAT-BUG-2128147 associated with any CVE identifiers?
Yes, REDHAT-BUG-2128147 is associated with the CVE identifier CVE-2022-40314.
Who reported REDHAT-BUG-2128147?
REDHAT-BUG-2128147 was reported by Paul Holden.