SUSE-RU-2024:0637-1: Recommended update for duktape
This update for duktape fixes the following issues: Ship libduktape206-32bit: needed by libproxy since version 0.5.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
suse/duktape-develto a version that resolves this vulnerability.Fixed in 2.6.0-150500.4.5.1 - Upgrade
Upgrade
suse/libduktape206to a version that resolves this vulnerability.Fixed in 2.6.0-150500.4.5.1 - Upgrade
Upgrade
suse/duktape-debugsourceto a version that resolves this vulnerability.Fixed in 2.6.0-150500.4.5.1 - Upgrade
Upgrade
suse/libduktape206-debuginfoto a version that resolves this vulnerability.Fixed in 2.6.0-150500.4.5.1 - Upgrade
Upgrade
suse/libduktape206to a version that resolves this vulnerability.Fixed in 32bit-2.6.0-150500.4.5.1 - Upgrade
Upgrade
suse/libduktape206to a version that resolves this vulnerability.Fixed in 32bit-debuginfo-2.6.0-150500.4.5.1 - Upgrade
Upgrade
suse/libduktape206to a version that resolves this vulnerability.Fixed in 64bit-2.6.0-150500.4.5.1 - Upgrade
Upgrade
suse/libduktape206to a version that resolves this vulnerability.Fixed in 64bit-debuginfo-2.6.0-150500.4.5.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-2024-637=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch openSUSE-SLE-15.5-2024-637=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Micro-5.5-2024-637=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Module-Basesystem-15-SP5-2024-637=1
Event History
Frequently Asked Questions
Is this update addressing a security vulnerability?
The provided advisory describes this as a recommended update and identifies no security vulnerability or CVE. Its stated purpose is to ship the 32-bit libduktape206 package required by libproxy since version 0.5.
Which systems may need this update?
The update applies to openSUSE Leap 15.5 and SUSE Basesystem Module 15-SP5 on the listed architectures, including aarch64, ppc64le, s390x, x86_64, and i586 where applicable. A separate openSUSE Leap 15.5 aarch64_ilp32 build is also listed.
What should administrators check before deploying it?
Administrators should determine whether libproxy version 0.5 or later requires 32-bit libduktape206 in their environment. The advisory specifically identifies libduktape206-32bit as the required component.