SUSE-RU-2024:0651-1: Recommended update for nftables
This update for nftables fixes the following issues: Enable python311 module (bsc#1219253).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
suse/nftables-debugsourceto a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
suse/nftables-develto a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
suse/nftablesto a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
suse/libnftables1to a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
suse/nftables-debuginfoto a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
suse/libnftables1-debuginfoto a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
suse/python311-nftablesto a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
suse/python3-nftablesto a version that resolves this vulnerability.Fixed in 0.9.8-150400.6.3.1 - Upgrade
Upgrade
nftablesto a version that resolves this vulnerability.Patch SUSE-2024-651 - Configuration
Enable the python311 module.
Python 3 Module 15-SP5 python311 module = enabled
Event History
Frequently Asked Questions
Which installations are most likely to need this update?
Systems using SUSE nftables packages are in scope, particularly those that need the Python 3.11 nftables module. The listed affected packages include nftables, libnftables1, python3-nftables, and python311-nftables, along with development, debug, and debuginfo packages.
Does the advisory identify an active security exploit or a specific attack condition?
No. The provided information describes this as a recommended update that enables the Python 3.11 module; it does not specify an exploit method, attacker prerequisites, exposure conditions, or evidence of active exploitation.