SUSE-SU-2023:4587-1: Security update for vim
This update for vim fixes the following issues: CVE-2023-5344: Heap-based Buffer Overflow in vim prior to 9.0.1969 (bsc#1215940) CVE-2023-5441: segfault in exmode when redrawing (bsc#1216001) CVE-2023-5535: use-after-free from bufcontentschanged() (bsc#1216167) CVE-2023-46246: Integer Overflow in :history command (bsc#1216696)
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
suse/vim-data-commonto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/vim-small-debuginfoto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/vim-smallto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/vim-debuginfoto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/vim-debugsourceto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/gvim-debuginfoto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/vimto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/gvimto a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade
suse/vim-datato a version that resolves this vulnerability.Fixed in 9.0.2103-150000.5.57.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Micro-5.3-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Micro-5.4-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Module-Basesystem-15-SP4-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-SLES_SAP-15-SP1-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SLE-Product-SLES_SAP-15-SP3-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SUSE-MicroOS-5.1-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-SUSE-MicroOS-5.2-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch SUSE-Storage-7.1-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch openSUSE-Leap-Micro-5.3-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch openSUSE-Leap-Micro-5.4-2023-4587=1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch openSUSE-SLE-15.4-2023-4587=1
Event History
Child vulnerabilities
Contains the following vulnerabilities.
Frequently Asked Questions
Which Vim vulnerabilities are addressed by this update?
The update addresses a heap-based buffer overflow (CVE-2023-5344), an exmode redraw segfault (CVE-2023-5441), a use-after-free in buf_contents_changed() (CVE-2023-5535), and an integer overflow in the :history command (CVE-2023-46246).
What Vim versions are known to be affected by the heap-based buffer overflow?
CVE-2023-5344 affects Vim versions prior to 9.0.1969. The provided information does not specify affected version ranges for the other issues.
Which SUSE packages are included in the update?
The update covers vim, gvim, vim-small, vim-data-common, and their listed debuginfo and debugsource packages.