UBUNTU-CVE-2015-3246: High severity ubuntu/libuser vulnerability
libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, directly modifies /etc/passwd, which allows local users to cause a denial of service (inconsistent file state) by causing an error during the modification. NOTE: this issue can be combined with CVE-2015-3245 to gain privileges.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/libuserto a version that resolves this vulnerability.Fixed in 1:0.56.9.dfsg.1-1.2ubuntu2+esm1