UBUNTU-CVE-2018-3760: High severity ubuntu/ruby-sprockets vulnerability
There is an information leak vulnerability in Sprockets. Versions Affected: 4.0.0.beta7 and lower, 3.7.1 and lower, 2.12.4 and lower. Specially crafted requests can be used to access files that exists on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/ruby-sprocketsto a version that resolves this vulnerability.Fixed in 3.7.0-1+deb9u1build0.18.04.1