UBUNTU-CVE-2026-104061: High severity ubuntu/scribus vulnerability
Scribus before 1.6.7 and 1.7.x before 1.7.4 contains a heap out-of-bounds write vulnerability in the scimgdataloaderpsd loader that uses unchecked PSD file values as lookup array indexes. Attackers can convince users to place or import a crafted PSD file to corrupt heap memory, causing crashes and potentially code execution as the user.
Affected Software
Event History
Frequently Asked Questions
What versions should be prioritized for remediation?
Scribus versions before 1.6.7 and 1.7.x versions before 1.7.4 are affected. Update to 1.6.7 or later in the 1.6 branch, or 1.7.4 or later in the 1.7 branch.
What does an attacker need to exploit this issue?
An attacker needs to convince a user to place or import a specially crafted PSD file in Scribus. The issue is locally exploitable and requires user interaction, but does not require prior privileges.
Who is exposed to this vulnerability?
Users who import or place PSD files in affected Scribus versions are exposed, particularly where PSD files are accepted from untrusted or external sources. Successful exploitation occurs in the context of the user running Scribus.
What can be done if an update cannot be installed immediately?
Do not import or place PSD files from untrusted sources until Scribus is updated. Treat externally supplied PSD files as potentially malicious because crafted file values can corrupt heap memory.