UBUNTU-CVE-2026-110354: High severity ubuntu/haproxy vulnerability
HAProxy 3 before 3.4.6 allows a remote unauthenticated attacker to cause a denial of service (persistent worker-thread CPU exhaustion) via an HTTP/1.1 chunked request. Although the H1 multiplexer drains the request before closing the stream, the parser repeatedly re-processes the same bytes without making progress. The affected thread stays busy at 100% CPU after timeouts expire and after the client disconnects, and repeated requests can consume all worker threads until the process is restarted.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/haproxyto a version that resolves this vulnerability.Fixed in 2.4.30-0ubuntu0.22.04.3 - Upgrade
Upgrade
ubuntu/haproxyto a version that resolves this vulnerability.Fixed in 2.8.30-0ubuntu0.24.04.2 - Upgrade
Upgrade
ubuntu/haproxyto a version that resolves this vulnerability.Fixed in 3.4.2-1ubuntu4.1 - Upgrade
Upgrade
ubuntu/haproxyto a version that resolves this vulnerability.Fixed in 3.2.25-0ubuntu0.26.04.2