UBUNTU-CVE-2026-111822: Medium severity ubuntu/activemq vulnerability
Improper invalidation of cached authorizations vulnerability in Apache ActiveMQ, Apache ActiveMQ Runtime Config. After the runtime configuration plugin removes a principal's write grant on a destination, an authenticated connection opened before the change can keep sending to that destination, including through a new anonymous producer, while fresh connections and new explicit producers are denied. This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ Runtime Config: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Apache ActiveMQto a version that resolves this vulnerability.Fixed in 6.4.0 - Upgrade
Upgrade
Apache ActiveMQto a version that resolves this vulnerability.Fixed in 6.3.3 - Upgrade
Upgrade
Apache ActiveMQto a version that resolves this vulnerability.Fixed in 5.19.12 - Upgrade
Upgrade
Apache ActiveMQ Runtime Configto a version that resolves this vulnerability.Fixed in 6.4.0 - Upgrade
Upgrade
Apache ActiveMQ Runtime Configto a version that resolves this vulnerability.Fixed in 6.3.3 - Upgrade
Upgrade
Apache ActiveMQ Runtime Configto a version that resolves this vulnerability.Fixed in 5.19.12