UBUNTU-CVE-2026-119722: High severity ubuntu/blender vulnerability
Blender before 4.5.15 and 5.x before 5.2.3 contains a heap out-of-bounds access vulnerability in readstruct() that skips size validation when a .blend file's SDNA struct layout compares equal. Attackers can supply a crafted .blend file with short blocks so field reads, writes, and pointer dereferences overrun heap memory, causing crashes or code execution.
Affected Software
Event History
Frequently Asked Questions
Who is exposed to this issue?
Ubuntu systems with vulnerable Blender versions are exposed when a user opens a crafted .blend file. Exploitation requires local access and user interaction, but does not require privileges.
What does an attacker need to exploit it?
An attacker needs to provide a malicious .blend file containing short blocks whose SDNA struct layout compares equal. The target must open that file in Blender.
What is the potential impact?
The malformed file can trigger heap out-of-bounds reads, writes, and pointer dereferences in read_struct(). This may cause Blender to crash or allow code execution in the context of the user running Blender.
Which Blender versions need remediation?
Blender versions before 4.5.15 and 5.x versions before 5.2.3 are affected. Update to 4.5.15 or later in the 4.5 series, or 5.2.3 or later in the 5.x series.