UBUNTU-CVE-2026-19666: High severity ubuntu/bind9 vulnerability

Published Sep 16, 2026
·
Updated

On a resolver configured to use dns64, if an applicable answer from the authoritative server is malformed in a specific way, the resolver named process will exit unexpectedly. This issue affects BIND 9 versions 9.11.0 through 9.18.50, 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.27-S1.

Affected Software

13 affected componentsFixes available
ubuntu/bind9<1:9.9.5.dfsg-3ubuntu0.19+esm15
1:9.9.5.dfsg-3ubuntu0.19+esm15
ubuntu/bind9<1:9.10.3.dfsg.P4-8ubuntu1.19+esm11
1:9.10.3.dfsg.P4-8ubuntu1.19+esm11
ubuntu/bind9<1:9.11.3+dfsg-1ubuntu1.19+esm6
1:9.11.3+dfsg-1ubuntu1.19+esm6
ubuntu/isc-dhcp*
ubuntu/bind9<1:9.18.30-0ubuntu0.20.04.2+esm3
1:9.18.30-0ubuntu0.20.04.2+esm3
ubuntu/bind9-libs*
ubuntu/bind9<1:9.18.39-0ubuntu0.22.04.7
1:9.18.39-0ubuntu0.22.04.7
ubuntu/bind9-libs*
ubuntu/bind9<1:9.18.39-0ubuntu0.24.04.8
1:9.18.39-0ubuntu0.24.04.8
ubuntu/isc-dhcp*
ubuntu/bind9<1:9.20.24-1ubuntu3.1
1:9.20.24-1ubuntu3.1
ubuntu/bind9<1:9.20.24-1ubuntu0.4
1:9.20.24-1ubuntu0.4
ubuntu/isc-dhcp*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.9.5.dfsg-3ubuntu0.19+esm15
  2. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.10.3.dfsg.P4-8ubuntu1.19+esm11
  3. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.11.3+dfsg-1ubuntu1.19+esm6
  4. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.18.30-0ubuntu0.20.04.2+esm3
  5. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.18.39-0ubuntu0.22.04.7
  6. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.18.39-0ubuntu0.24.04.8
  7. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.20.24-1ubuntu3.1
  8. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.20.24-1ubuntu0.4

Event History

Sep 16, 2026
CVE Published
via OSV·03:17 PM
Data Sourced
via OSV·03:17 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this denial-of-service condition?

Resolvers running the BIND named process are affected when they are configured to use dns64 and fall within the listed affected BIND version ranges. The provided information does not establish that deployments without dns64 are affected.

2

What must an attacker do to trigger the failure?

An attacker needs to cause the resolver to process an applicable authoritative-server answer that is malformed in a specific way. No authentication or user interaction is required according to the supplied severity vector.

3

What is the operational impact if exploitation succeeds?

The named resolver process exits unexpectedly, causing a denial of service until the service is restarted or otherwise recovered.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203