UBUNTU-CVE-2026-19941: Medium severity ubuntu/bind9 vulnerability

Published Sep 16, 2026
·
Updated

An inapplicable NSEC record may be accepted by a named resolver as proof that no wildcard exists, which could allow an attacker at the same or an upstream level of the zone name to mask the existence of a victim's wildcard record. This issue affects BIND 9 versions 9.11.0 through 9.18.50, 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.27-S1.

Affected Software

13 affected componentsFixes available
ubuntu/bind9<1:9.9.5.dfsg-3ubuntu0.19+esm15
1:9.9.5.dfsg-3ubuntu0.19+esm15
ubuntu/bind9<1:9.10.3.dfsg.P4-8ubuntu1.19+esm11
1:9.10.3.dfsg.P4-8ubuntu1.19+esm11
ubuntu/bind9<1:9.11.3+dfsg-1ubuntu1.19+esm6
1:9.11.3+dfsg-1ubuntu1.19+esm6
ubuntu/isc-dhcp*
ubuntu/bind9<1:9.18.30-0ubuntu0.20.04.2+esm3
1:9.18.30-0ubuntu0.20.04.2+esm3
ubuntu/bind9-libs*
ubuntu/bind9<1:9.18.39-0ubuntu0.22.04.7
1:9.18.39-0ubuntu0.22.04.7
ubuntu/bind9-libs*
ubuntu/bind9<1:9.18.39-0ubuntu0.24.04.8
1:9.18.39-0ubuntu0.24.04.8
ubuntu/isc-dhcp*
ubuntu/bind9<1:9.20.24-1ubuntu3.1
1:9.20.24-1ubuntu3.1
ubuntu/bind9<1:9.20.24-1ubuntu0.4
1:9.20.24-1ubuntu0.4
ubuntu/isc-dhcp*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.9.5.dfsg-3ubuntu0.19+esm15
  2. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.10.3.dfsg.P4-8ubuntu1.19+esm11
  3. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.11.3+dfsg-1ubuntu1.19+esm6
  4. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.18.30-0ubuntu0.20.04.2+esm3
  5. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.18.39-0ubuntu0.22.04.7
  6. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.18.39-0ubuntu0.24.04.8
  7. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.20.24-1ubuntu3.1
  8. Upgrade

    Upgrade ubuntu/bind9 to a version that resolves this vulnerability.

    Fixed in 1:9.20.24-1ubuntu0.4

Event History

Sep 16, 2026
CVE Published
via OSV·02:17 PM
Data Sourced
via OSV·02:17 PM
DescriptionSeverityAffected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203