UBUNTU-CVE-2026-26961: Medium severity ubuntu/ruby-rack vulnerability

Published Apr 2, 2026
·
Updated

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser extracts the boundary parameter from multipart/form-data using a greedy regular expression. When a Content-Type header contains multiple boundary parameters, Rack selects the last one rather than the first. In deployments where an upstream proxy, WAF, or intermediary interprets the first boundary parameter, this mismatch can allow an attacker to smuggle multipart content past upstream inspection and have Rack parse a different body structure than the intermediary validated. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Affected Software

7 affected componentsFixes available
ubuntu/ruby-rack*
ubuntu/ruby-rack*
ubuntu/ruby-rack*
ubuntu/ruby-rack<2.1.4-5ubuntu1.2+esm3
2.1.4-5ubuntu1.2+esm3
ubuntu/ruby-rack<2.2.7-1ubuntu0.7
2.2.7-1ubuntu0.7
ubuntu/ruby-rack<3.1.16-0.1ubuntu0.3
3.1.16-0.1ubuntu0.3
ubuntu/ruby-rack*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 2.1.4-5ubuntu1.2+esm3
  2. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 2.2.7-1ubuntu0.7
  3. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 3.1.16-0.1ubuntu0.3
  4. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 2.2.23
  5. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 3.1.21
  6. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 3.2.6

Event History

Apr 2, 2026
CVE Published
via OSV·05:16 PM
Data Sourced
via OSV·05:16 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this parsing mismatch?

Deployments are exposed when Rack processes multipart/form-data behind an upstream proxy, WAF, or other intermediary that interprets the first boundary parameter while vulnerable Rack selects the last one. The issue affects Rack versions before 2.2.23, 3.1.21, and 3.2.6.

2

What must an attacker do to exploit the issue?

An attacker must send a multipart/form-data request with multiple boundary parameters in the Content-Type header. Exploitation depends on an intermediary validating the request using the first boundary while Rack parses it using the last boundary.

3

What is the immediate remediation?

Upgrade Rack to version 2.2.23, 3.1.21, or 3.2.6, as appropriate for the deployed release line. These versions patch the boundary-parameter parsing behavior.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203