UBUNTU-CVE-2026-34230: High severity ubuntu/ruby-rack vulnerability

Published Apr 2, 2026
·
Updated

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.selectbestencoding processes Accept-Encoding values with quadratic time complexity when the header contains many wildcard () entries. Because this method is used by Rack::Deflater to choose a response encoding, an unauthenticated attacker can send a single request with a crafted Accept-Encoding header and cause disproportionate CPU consumption on the compression middleware path. This results in a denial of service condition for applications using Rack::Deflater. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Affected Software

7 affected componentsFixes available
ubuntu/ruby-rack<1.5.2-3+deb8u3ubuntu1~esm11
1.5.2-3+deb8u3ubuntu1~esm11
ubuntu/ruby-rack<1.6.4-3ubuntu0.2+esm10
1.6.4-3ubuntu0.2+esm10
ubuntu/ruby-rack<1.6.4-4ubuntu0.2+esm10
1.6.4-4ubuntu0.2+esm10
ubuntu/ruby-rack<2.1.4-5ubuntu1.2+esm3
2.1.4-5ubuntu1.2+esm3
ubuntu/ruby-rack<2.2.7-1ubuntu0.7
2.2.7-1ubuntu0.7
ubuntu/ruby-rack<3.1.16-0.1ubuntu0.3
3.1.16-0.1ubuntu0.3
ubuntu/ruby-rack*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 1.5.2-3+deb8u3ubuntu1~esm11
  2. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 1.6.4-3ubuntu0.2+esm10
  3. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 1.6.4-4ubuntu0.2+esm10
  4. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 2.1.4-5ubuntu1.2+esm3
  5. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 2.2.7-1ubuntu0.7
  6. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 3.1.16-0.1ubuntu0.3
  7. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 2.2.23
  8. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 3.1.21
  9. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 3.2.6

Event History

Apr 2, 2026
CVE Published
via OSV·05:16 PM
Data Sourced
via OSV·05:16 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this denial-of-service issue?

Applications using Rack::Deflater are affected because it invokes Rack::Utils.select_best_encoding to select a response encoding. Applications that do not use this compression middleware are not identified as affected by the provided information.

2

What does an attacker need to exploit the issue?

An attacker needs only network access to send a single request containing a crafted Accept-Encoding header with many wildcard (*) entries. No authentication or user interaction is required.

3

What is the practical impact of a successful attack?

The crafted header causes quadratic-time processing in the compression middleware path, resulting in disproportionate CPU consumption. This can cause a denial-of-service condition.

4

Which Rack versions contain the fix?

The issue is patched in Rack versions 2.2.23, 3.1.21, and 3.2.6.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203