UBUNTU-CVE-2026-34826: High severity ubuntu/ruby-rack vulnerability

Published Apr 2, 2026
·
Updated

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.getbyteranges parses the HTTP Range header without limiting the number of individual byte ranges. Although the existing fix for CVE-2024-26141 rejects ranges whose total byte coverage exceeds the file size, it does not restrict the count of ranges. An attacker can supply many small overlapping ranges such as 0-0,0-0,0-0,... to trigger disproportionate CPU, memory, I/O, and bandwidth consumption per request. This results in a denial of service condition in Rack file-serving paths that process multipart byte range responses. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Affected Software

7 affected componentsFixes available
ubuntu/ruby-rack*
ubuntu/ruby-rack<1.6.4-3ubuntu0.2+esm10
1.6.4-3ubuntu0.2+esm10
ubuntu/ruby-rack<1.6.4-4ubuntu0.2+esm10
1.6.4-4ubuntu0.2+esm10
ubuntu/ruby-rack<2.1.4-5ubuntu1.2+esm3
2.1.4-5ubuntu1.2+esm3
ubuntu/ruby-rack<2.2.7-1ubuntu0.7
2.2.7-1ubuntu0.7
ubuntu/ruby-rack<3.1.16-0.1ubuntu0.3
3.1.16-0.1ubuntu0.3
ubuntu/ruby-rack*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 1.6.4-3ubuntu0.2+esm10
  2. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 1.6.4-4ubuntu0.2+esm10
  3. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 2.1.4-5ubuntu1.2+esm3
  4. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 2.2.7-1ubuntu0.7
  5. Upgrade

    Upgrade ubuntu/ruby-rack to a version that resolves this vulnerability.

    Fixed in 3.1.16-0.1ubuntu0.3
  6. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 2.2.23
  7. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 3.1.21
  8. Upgrade

    Upgrade Rack to a version that resolves this vulnerability.

    Fixed in 3.2.6

Event History

Apr 2, 2026
CVE Published
via OSV·05:16 PM
Data Sourced
via OSV·05:16 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this denial-of-service issue?

Ubuntu systems using ruby-rack versions earlier than 2.2.23, 3.1.21, or 3.2.6 are affected when Rack file-serving paths process multipart HTTP byte-range responses.

2

What does an attacker need to exploit it?

An unauthenticated remote attacker can send an HTTP Range header containing many small overlapping ranges. No user interaction or privileges are required.

3

What is the operational impact of a malicious request?

Processing a request with many overlapping ranges can cause disproportionate CPU, memory, I/O, and bandwidth consumption, resulting in denial of service.

4

How can this issue be remediated?

Update Rack to version 2.2.23, 3.1.21, or 3.2.6, as applicable to the deployed release line.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203