UBUNTU-CVE-2026-34827: High severity ubuntu/ruby-rack vulnerability
Rack is a modular Ruby web server interface. From versions 3.0.0.beta1 to before 3.1.21, and 3.2.0 to before 3.2.6, Rack::Multipart::Parser#handlemimehead parses quoted multipart parameters such as Content-Disposition: form-data; name="..." using repeated String#index searches combined with String#slice! prefix deletion. For escape-heavy quoted values, this causes super-linear processing. An unauthenticated attacker can send a crafted multipart/form-data request containing many parts with long backslash-escaped parameter values to trigger excessive CPU usage during multipart parsing. This results in a denial of service condition in Rack applications that accept multipart form data. This issue has been patched in versions 3.1.21 and 3.2.6.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/ruby-rackto a version that resolves this vulnerability.Fixed in 3.1.16-0.1ubuntu0.3 - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Fixed in 3.1.21 - Upgrade
Upgrade
Rackto a version that resolves this vulnerability.Fixed in 3.2.6
Event History
Frequently Asked Questions
Which applications are exposed to this denial of service?
Rack applications using affected Rack releases are exposed if they accept multipart/form-data requests. The issue affects Rack versions 3.0.0.beta1 through before 3.1.21, and 3.2.0 through before 3.2.6.
Does exploitation require authentication or user interaction?
No. An unauthenticated attacker can exploit the issue remotely by sending a crafted multipart/form-data request; no user interaction is required.
What does an exploit request need to contain?
The request needs many multipart parts with long quoted parameter values containing many backslash escapes. These values trigger super-linear CPU processing while Rack parses multipart headers.
What should be done to remediate the issue?
Update Rack to version 3.1.21 or later in the 3.1 series, or version 3.2.6 or later in the 3.2 series. These versions contain the patch.