UBUNTU-CVE-2026-77692: High severity ubuntu/isc-dhcp vulnerability
An attacker can cause named to abort by sending a crafted DNS-over-HTTPS request with a cryptographically invalid SIG(0) record, and then closing the transport connection prematurely. This issue affects BIND 9 versions 9.20.0 through 9.20.27, 9.21.0 through 9.21.25, and 9.20.9-S1 through 9.20.27-S1.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.20.24-1ubuntu3.1 - Upgrade
Upgrade
ubuntu/bind9to a version that resolves this vulnerability.Fixed in 1:9.20.24-1ubuntu0.4